summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-04 00:06:07 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 16:23:34 +0100
commitfb3b6fa6ed33b54c6315c0b903b30de35a8ef876 (patch)
tree852f83a2b6b1fc1e6ea94adf7e066cf202cc6bec /x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild
parentmedia-gfx/optipng: Drop old (EAPI 6) (diff)
downloadgentoo-fb3b6fa6ed33b54c6315c0b903b30de35a8ef876.tar.gz
gentoo-fb3b6fa6ed33b54c6315c0b903b30de35a8ef876.tar.bz2
gentoo-fb3b6fa6ed33b54c6315c0b903b30de35a8ef876.zip
x11-misc/openbox-menu: update to 0.8.1
Updated SRC_URI (#739808), migrated to EAPI 7. Bug: https://bugs.gentoo.org/739808 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17404 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild')
-rw-r--r--x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild b/x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild
new file mode 100644
index 000000000000..ecb08aa5c8d3
--- /dev/null
+++ b/x11-misc/openbox-menu/openbox-menu-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Another dynamic menu generator for Openbox"
+HOMEPAGE="http://fabrice.thiroux.free.fr/openbox-menu_en.html"
+SRC_URI="https://github.com/fabriceT/openbox-menu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+icons svg"
+REQUIRED_USE="svg? ( icons )"
+
+DEPEND="
+ dev-libs/glib:2
+ lxde-base/menu-cache
+ x11-libs/gtk+:2
+"
+RDEPEND="
+ ${DEPEND}
+ icons? ( x11-wm/openbox[imlib,svg?] )
+ !icons? ( x11-wm/openbox )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_compile() {
+ emake CC=$(tc-getCC) PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ WITH_ICONS=$(usex icons '1' '0') \
+ WITH_SVG=$(usex svg '1' '0')
+}