summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2023-03-06 01:26:23 +0300
committerSam James <sam@gentoo.org>2023-03-11 17:15:12 +0000
commitb76f091b2cd8248248a55d9e8af6c3ea829e41ee (patch)
tree369948b3439c834477aac6a392155d2b7949ab07 /x11-misc/x11vnc
parentapp-crypt/tpm2-tss: Build fix for multilib systems (diff)
downloadgentoo-b76f091b2cd8248248a55d9e8af6c3ea829e41ee.tar.gz
gentoo-b76f091b2cd8248248a55d9e8af6c3ea829e41ee.tar.bz2
gentoo-b76f091b2cd8248248a55d9e8af6c3ea829e41ee.zip
x11-misc/x11vnc: fix implicit function declarations in configure
Also fix issue reported by checkbashisms and remove trailing spaces from init script. Closes: https://bugs.gentoo.org/849227 Closes: https://bugs.gentoo.org/898398 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.16-implicit-function-declaration.patch26
-rw-r--r--x11-misc/x11vnc/files/x11vnc.init.d-r18
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.16-r7.ebuild5
3 files changed, 33 insertions, 6 deletions
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.16-implicit-function-declaration.patch b/x11-misc/x11vnc/files/x11vnc-0.9.16-implicit-function-declaration.patch
new file mode 100644
index 000000000000..c6d1c494bd23
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.16-implicit-function-declaration.patch
@@ -0,0 +1,26 @@
+From 351d27d4a846e3d0e5c724e067f44b52e04402f1 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Mon, 6 Mar 2023 00:57:20 +0300
+Subject: [PATCH] Drop AC_FUNC_STAT macro
+
+This macro is obsolescent and doesn't work with
+-Werror=implicit-function-declaration compiler flag
+---
+ configure.ac | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6b62ac5..5a386db 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -474,7 +474,6 @@ if test $inaddrt = no ; then
+ fi
+ # Checks for library functions.
+ AC_FUNC_MEMCMP
+-AC_FUNC_STAT
+ AC_FUNC_STRFTIME
+ AC_FUNC_VPRINTF
+ AC_FUNC_FORK
+--
+2.39.2
+
diff --git a/x11-misc/x11vnc/files/x11vnc.init.d-r1 b/x11-misc/x11vnc/files/x11vnc.init.d-r1
index 04c36ea361db..8907b3858a31 100644
--- a/x11-misc/x11vnc/files/x11vnc.init.d-r1
+++ b/x11-misc/x11vnc/files/x11vnc.init.d-r1
@@ -16,8 +16,8 @@ checkconfig() {
X11VNC_RFBPORT=${X11VNC_RFBPORT:-5900}
X11VNC_DISPLAY=${X11VNC_DISPLAY:-:0}
X11VNC_LOG=${X11VNC_LOG:-/var/log/x11vnc}
-
- X11VNC_AUTH="/var/run/x11vnc-${X11VNC_DISPLAY}"
+
+ X11VNC_AUTH="/var/run/x11vnc-${X11VNC_DISPLAY}"
if [ -n "${X11VNC_AUTOPORT}" ]; then
X11VNC_PORT=""
@@ -30,7 +30,7 @@ checkconfig() {
checkpath -q -f -m 0600 -o root:root "${X11VNC_RFBAUTH}"
# Attempt to find X-Auth file
- if ! type xauth > /dev/null 2>&1 ||
+ if ! command -v xauth > /dev/null 2>&1 ||
! xauth -f /root/.Xauthority extract - "${X11VNC_DISPLAY}" > "${X11VNC_AUTH}" 2>/dev/null ||
[ ! -s "${X11VNC_AUTH}" ]; then
# Let x11vnc guess at auth
@@ -43,7 +43,7 @@ checkconfig() {
if [ ! -f "${X11VNC_AUTH}" ]; then
eerror "Specified X-Authority file '${X11VNC_AUTH}' not found!"
return 1
- fi
+ fi
}
start() {
diff --git a/x11-misc/x11vnc/x11vnc-0.9.16-r7.ebuild b/x11-misc/x11vnc/x11vnc-0.9.16-r7.ebuild
index 74b94b9ee0ae..63e3af4a67a1 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.16-r7.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.16-r7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -43,6 +43,7 @@ PATCHES=(
"${FILESDIR}"/${P}-anonymous-ssl.patch # https://github.com/LibVNC/x11vnc/pull/85
"${FILESDIR}"/${P}-fno-common.patch
"${FILESDIR}"/${P}-CVE-2020-29074.patch
+ "${FILESDIR}"/${P}-implicit-function-declaration.patch
)
src_prepare() {