summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:20:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:20:31 +0100
commit8f7ccbb5101407d3e00ac2199c28f208aaae956a (patch)
tree846d5495d46d23533b83d5ee9030e1a24e87c8af /x11-misc/xdock
parentx11-misc/lineakd: disable static libs (diff)
downloadgentoo-8f7ccbb5101407d3e00ac2199c28f208aaae956a.tar.gz
gentoo-8f7ccbb5101407d3e00ac2199c28f208aaae956a.tar.bz2
gentoo-8f7ccbb5101407d3e00ac2199c28f208aaae956a.zip
x11-misc/xdock: disable static-libs
Closes: https://bugs.gentoo.org/726294 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/xdock')
-rw-r--r--x11-misc/xdock/xdock-0.3.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-misc/xdock/xdock-0.3.0.ebuild b/x11-misc/xdock/xdock-0.3.0.ebuild
index 63c9381744b7..379d89b1ad35 100644
--- a/x11-misc/xdock/xdock-0.3.0.ebuild
+++ b/x11-misc/xdock/xdock-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -23,3 +23,12 @@ src_prepare() {
sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
eautoreconf
}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}