summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-23 15:45:41 +0100
committerSam James <sam@gentoo.org>2024-08-23 15:45:41 +0100
commit2e3800a592ff6bfe6fe6075e46ff3e5b6851a2ec (patch)
tree342379c2fb93fffa457e083ce4a19c4472e154de /x11-misc/xvfb-run
parentdev-util/perf: fix assert use, as in bpftool (diff)
downloadgentoo-2e3800a592ff6bfe6fe6075e46ff3e5b6851a2ec.tar.gz
gentoo-2e3800a592ff6bfe6fe6075e46ff3e5b6851a2ec.tar.bz2
gentoo-2e3800a592ff6bfe6fe6075e46ff3e5b6851a2ec.zip
x11-misc/xvfb-run: fix filterdiff error handling
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xvfb-run')
-rw-r--r--x11-misc/xvfb-run/xvfb-run-21.1.10.1.ebuild3
-rw-r--r--x11-misc/xvfb-run/xvfb-run-21.1.11.2.ebuild1
-rw-r--r--x11-misc/xvfb-run/xvfb-run-21.1.12.1.ebuild1
-rw-r--r--x11-misc/xvfb-run/xvfb-run-21.1.7.1.ebuild5
4 files changed, 7 insertions, 3 deletions
diff --git a/x11-misc/xvfb-run/xvfb-run-21.1.10.1.ebuild b/x11-misc/xvfb-run/xvfb-run-21.1.10.1.ebuild
index cc9e028b4a34..d3f185b1c52f 100644
--- a/x11-misc/xvfb-run/xvfb-run-21.1.10.1.ebuild
+++ b/x11-misc/xvfb-run/xvfb-run-21.1.10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,6 +22,7 @@ S="${WORKDIR}"/
src_prepare() {
# Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+ assert "filterdiff+patch failed"
eapply_user
}
diff --git a/x11-misc/xvfb-run/xvfb-run-21.1.11.2.ebuild b/x11-misc/xvfb-run/xvfb-run-21.1.11.2.ebuild
index 1191b6b39e1c..d3f185b1c52f 100644
--- a/x11-misc/xvfb-run/xvfb-run-21.1.11.2.ebuild
+++ b/x11-misc/xvfb-run/xvfb-run-21.1.11.2.ebuild
@@ -22,6 +22,7 @@ S="${WORKDIR}"/
src_prepare() {
# Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+ assert "filterdiff+patch failed"
eapply_user
}
diff --git a/x11-misc/xvfb-run/xvfb-run-21.1.12.1.ebuild b/x11-misc/xvfb-run/xvfb-run-21.1.12.1.ebuild
index 1191b6b39e1c..d3f185b1c52f 100644
--- a/x11-misc/xvfb-run/xvfb-run-21.1.12.1.ebuild
+++ b/x11-misc/xvfb-run/xvfb-run-21.1.12.1.ebuild
@@ -22,6 +22,7 @@ S="${WORKDIR}"/
src_prepare() {
# Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+ assert "filterdiff+patch failed"
eapply_user
}
diff --git a/x11-misc/xvfb-run/xvfb-run-21.1.7.1.ebuild b/x11-misc/xvfb-run/xvfb-run-21.1.7.1.ebuild
index b37ac978a797..22f09ed6cbbd 100644
--- a/x11-misc/xvfb-run/xvfb-run-21.1.7.1.ebuild
+++ b/x11-misc/xvfb-run/xvfb-run-21.1.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,8 @@ S="${WORKDIR}"/
src_prepare() {
# Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
- filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+ filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch
+ assert "filterdiff+patch failed"
eapply_user
}