summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-07-04 16:53:23 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-07-04 16:53:23 +0200
commit22c2ab8255a4ab969d5d97e2cf184da4dcd79e27 (patch)
tree255ab837475070a9de0ffc06ccf74eaafca113f5 /x11-plugins/wmcliphist
parentmedia-fonts/quivira: version bump to 4.1, address repoman complaints (diff)
downloadgentoo-22c2ab8255a4ab969d5d97e2cf184da4dcd79e27.tar.gz
gentoo-22c2ab8255a4ab969d5d97e2cf184da4dcd79e27.tar.bz2
gentoo-22c2ab8255a4ab969d5d97e2cf184da4dcd79e27.zip
x11-plugins/wmcliphist: depend on gtk+ with USE=X, bug #587044
Reported by Toralf Förster <toralf.foerster@gmx.de> Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-plugins/wmcliphist')
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-2.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-2.1-r2.ebuild b/x11-plugins/wmcliphist/wmcliphist-2.1-r2.ebuild
new file mode 100644
index 000000000000..4b41a5e9edb4
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-2.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmcliphist"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3[X]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/dockapps
+
+src_prepare() {
+ default
+
+ sed -e '/^PREFIX/s:=.*:=/usr:' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ newdoc ${PN}rc ${PN}rc.sample
+}