summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmstickynotes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmstickynotes')
-rw-r--r--x11-plugins/wmstickynotes/Manifest1
-rw-r--r--x11-plugins/wmstickynotes/files/wmstickynotes-0.2-gold.patch28
-rw-r--r--x11-plugins/wmstickynotes/metadata.xml10
-rw-r--r--x11-plugins/wmstickynotes/wmstickynotes-0.2.ebuild23
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-plugins/wmstickynotes/Manifest b/x11-plugins/wmstickynotes/Manifest
new file mode 100644
index 000000000000..f309d240aa4e
--- /dev/null
+++ b/x11-plugins/wmstickynotes/Manifest
@@ -0,0 +1 @@
+DIST wmstickynotes-0.2.tar.gz 107432 SHA256 e6c939e0a2aeaacef54f1fde6f08a0165b9267e253f398cc859aab2e9ed201f2
diff --git a/x11-plugins/wmstickynotes/files/wmstickynotes-0.2-gold.patch b/x11-plugins/wmstickynotes/files/wmstickynotes-0.2-gold.patch
new file mode 100644
index 000000000000..360140a85ed6
--- /dev/null
+++ b/x11-plugins/wmstickynotes/files/wmstickynotes-0.2-gold.patch
@@ -0,0 +1,28 @@
+ Makefile.am | 2 +-
+ Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7c69428..bccf1d4 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,5 +10,5 @@ AUTOMAKE_OPTIONS = gnu
+ bin_PROGRAMS = wmstickynotes
+ wmstickynotes_SOURCES = wmstickynotes.c wmstickynotes.h wmstickynotes.xpm delete_button.xpm resize_button.xpm
+
+-wmstickynotes_LDADD = @GTK_LIBS@
++wmstickynotes_LDADD = @GTK_LIBS@ -lX11
+ EXTRA_DIST = THANKS
+diff --git a/Makefile.in b/Makefile.in
+index 91b19bd..fd883f2 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -182,7 +182,7 @@ top_srcdir = @top_srcdir@
+ AM_CFLAGS = @GTK_CFLAGS@
+ AUTOMAKE_OPTIONS = gnu
+ wmstickynotes_SOURCES = wmstickynotes.c wmstickynotes.h wmstickynotes.xpm delete_button.xpm resize_button.xpm
+-wmstickynotes_LDADD = @GTK_LIBS@
++wmstickynotes_LDADD = @GTK_LIBS@ -lX11
+ EXTRA_DIST = THANKS
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
diff --git a/x11-plugins/wmstickynotes/metadata.xml b/x11-plugins/wmstickynotes/metadata.xml
new file mode 100644
index 000000000000..d6e04f210d1a
--- /dev/null
+++ b/x11-plugins/wmstickynotes/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wmstickynotes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmstickynotes/wmstickynotes-0.2.ebuild b/x11-plugins/wmstickynotes/wmstickynotes-0.2.ebuild
new file mode 100644
index 000000000000..643b17fc1bd2
--- /dev/null
+++ b/x11-plugins/wmstickynotes/wmstickynotes-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A dockapp for keeping small notes around on the desktop"
+HOMEPAGE="http://wmstickynotes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gold.patch
+}