summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-13 00:14:54 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-13 00:16:02 +0200
commit087e1dfac479537b4f6cb541b5b0368bf924af69 (patch)
tree4eaacd733c1f546c2d41856a673b2361b65cfcb7 /x11-plugins
parentkde-base/smokekde: Drop Nepomuk support (diff)
downloadgentoo-087e1dfac479537b4f6cb541b5b0368bf924af69.tar.gz
gentoo-087e1dfac479537b4f6cb541b5b0368bf924af69.tar.bz2
gentoo-087e1dfac479537b4f6cb541b5b0368bf924af69.zip
x11-plugins/wmcliphist: fix PREFIX during src_compile (bug 556862, thanks Robert Cernansky).
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild b/x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild
new file mode 100644
index 000000000000..f15d4cc7237d
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-2.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmcliphist"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/dockapps
+
+src_prepare() {
+ sed -e '/^PREFIX/s:=.*:=/usr:' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ dodoc ChangeLog README
+ newdoc ${PN}rc ${PN}rc.sample
+}