summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-11 05:13:28 +0000
committerSam James <sam@gentoo.org>2023-01-11 05:15:22 +0000
commitbdff603b4dec2c1ce85a7f164454194b531c28b3 (patch)
treed4949b32aea67e92dce0e12cf0dfe6a7113675e7 /x11-terms/xterm
parentmedia-gfx/scrot: add xinerama dep (diff)
downloadgentoo-bdff603b4dec2c1ce85a7f164454194b531c28b3.tar.gz
gentoo-bdff603b4dec2c1ce85a7f164454194b531c28b3.tar.bz2
gentoo-bdff603b4dec2c1ce85a7f164454194b531c28b3.zip
x11-terms/xterm: add 378
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms/xterm')
-rw-r--r--x11-terms/xterm/Manifest2
-rw-r--r--x11-terms/xterm/xterm-378.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index c5dcaf7c38ac..4bedd63c2da9 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -2,3 +2,5 @@ DIST xterm-376.tgz 1524619 BLAKE2B eae78890a33995e8ca5ffabe742c7adf0e29f41b373c5
DIST xterm-376.tgz.asc 729 BLAKE2B a2dc9fd23ebb066dc7bb691a72a88ea0f630e64507eb9741097e8ca1973e09a39765974e32b3ce384d29e79d431a72b6f89f3af646dffa5ca92b569a8956996e SHA512 6e6f91e57b686e6590448d50549e671ba89015096adffa8e7e4eae4ca254346b92dce45cdb57bc8987caad6a1141f30d997fdf04d83791209e56c3646a9dbc8e
DIST xterm-377.tgz 1527178 BLAKE2B 0e7436d3eae4264d4974026b3e26588cfeb2d6e630e01cdfb9158ade4b9376754c832cffc59be88861469c461ace19ec2ecd9f808ac52cd967301502ec5ccc6e SHA512 e74fef6edae3162a7395e5654e78afcb3cb816dbfeabf46dacab48ed872a7aa7ee8c2be32f14a67d51bc207a2bc914cdc9b446985aed73240086e2320127f7c9
DIST xterm-377.tgz.asc 729 BLAKE2B b20e862876e093c270a4cdc46b47414c2fb4eb36b99867c3c93d31f785b92ebf90918053dfa11f999da091f2d2ce6326068f2e0acc8055f768e1be39d6a89d75 SHA512 4f93e969053aa3d7f568c7dbc05cecb19d60fb6b5f54c305ea0727f1a11796f882530a403dbec6f9d5d916a43719bd2b62179510e7f6083972ea37b2837af4d2
+DIST xterm-378.tgz 1529140 BLAKE2B 73524a7e382c5e69122432927f9facf525981258df04ac06bd181b9ca8ccddc6387903922a28d17a0d2e8d35c0f459f76fc8aeec9eb43dfd1123cd4f7b1a080c SHA512 71515ecde2f050c17613f5851d00893326338dc31bd4db6a737792d2848d807c8d82ae9c49f8f673150b042c065d5b2a44da8d0cbcdbffbf55fe0919a1ee9047
+DIST xterm-378.tgz.asc 729 BLAKE2B c12827b98ce4a498fd7ae7b223391c6f7193a5f85709bbc2758499db02405f618fab80c2fba21b48181f2330eccd08cd7201fab3671ea239f01b3749d18a7bd5 SHA512 c7e1845375a0bbd477ae78e4449cd2b16206669f042733acf527057dfb3f58582f26d81509383f312cd4f37043ae3754131412ae63571320c4b9fdb00da11c86
diff --git a/x11-terms/xterm/xterm-378.ebuild b/x11-terms/xterm/xterm-378.ebuild
new file mode 100644
index 000000000000..433b5518e63a
--- /dev/null
+++ b/x11-terms/xterm/xterm-378.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit desktop flag-o-matic toolchain-funcs verify-sig xdg
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+DEPEND="
+ kernel_linux? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+DEPEND+=" x11-base/xorg-proto"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+src_configure() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+
+ # bug #454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-icon-theme=hicolor
+ --with-icondir="${EPREFIX}"/usr/share/icons
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ sed -i -e 's/_48x48//g' *.desktop || die
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}