summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gnome-icon-theme-extras
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gnome-icon-theme-extras')
-rw-r--r--x11-themes/gnome-icon-theme-extras/Manifest2
-rw-r--r--x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild39
-rw-r--r--x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.6.2.ebuild37
-rw-r--r--x11-themes/gnome-icon-theme-extras/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-themes/gnome-icon-theme-extras/Manifest b/x11-themes/gnome-icon-theme-extras/Manifest
new file mode 100644
index 000000000000..6cd679ed5083
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-extras/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-icon-theme-extras-3.12.0.tar.xz 1729576 SHA256 4eec6cea8a7b09c4ed6ebab1a3b42539b9c61a53bec4b8872e774611cc619608 SHA512 e74b1b31cdc6bc2d9410c874b8e0891521a657cd3cc86c391f58709fa2d35d9e983bd50faaca1f1378a11d716502143bc2b41942a9cdcd3caa2280429bb3f6f5 WHIRLPOOL 386b24c827dae192f87e58a42919fac94d52f112be1b497e5dff1c75cf9af8355a7116971474ef672645ebb98d04928050f43f4735c5c7a01ac9a5af8241e149
+DIST gnome-icon-theme-extras-3.6.2.tar.xz 1668040 SHA256 93aaaadf40c85ebc42232a4d8e45ca507754b8e1271e797bbcdaded52bd03ec7 SHA512 51d4bc256b9b72cf9f72067e8b5e7e3c95e1026b83af1ce092390299d220b73fdb8ef9b2f2f4946b97d594ff22925e574e84095592241eeb3b14fa95e4187cba WHIRLPOOL 339f5816a0d50f1baa247859c1322a6c1d6ce9280c9ee286f7929725ca73007b61fe6f442836f463f8bd072f056a39c91f71c92c3bc2c45434252a2ffd982cd3
diff --git a/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
new file mode 100644
index 000000000000..2dc5b108d9ed
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Extra GNOME icons for specific devices and file types"
+HOMEPAGE="http://www.gnome.org/ http://git.gnome.org/browse/gnome-icon-theme-extras/"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+# FIXME: double check potential LINGUAS problem
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Always use pre-rendered icons
+ # FIXME: changing configure.ac triggers maintainer-mode rebuild
+ sed -e 's/"x$allow_rendering" = "xyes"/"x$allow_rendering" = "xdonotwant"/' \
+ -i configure || die
+}
+
+src_configure() {
+ gnome2_src_configure --enable-icon-mapping
+}
diff --git a/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.6.2.ebuild b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.6.2.ebuild
new file mode 100644
index 000000000000..22b2ab746a58
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Extra GNOME icons for specific devices and file types"
+HOMEPAGE="http://www.gnome.org/ http://git.gnome.org/browse/gnome-icon-theme-extras/"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ virtual/pkgconfig"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+# FIXME: double check potential LINGUAS problem
+
+src_prepare() {
+ DOCS="AUTHORS README NEWS"
+ G2CONF="${G2CONF} --enable-icon-mapping"
+
+ gnome2_src_prepare
+
+ # Always use pre-rendered icons
+ # FIXME: changing configure.ac triggers maintainer-mode rebuild
+ sed -e 's/"x$allow_rendering" = "xyes"/"x$allow_rendering" = "xdonotwant"/' \
+ -i configure || die
+}
diff --git a/x11-themes/gnome-icon-theme-extras/metadata.xml b/x11-themes/gnome-icon-theme-extras/metadata.xml
new file mode 100644
index 000000000000..6e0e2ecb48ca
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-extras/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>