summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-06-26 23:10:17 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-06-27 21:38:35 +0800
commit68e45f8e359cda963c67c7e2755effcbb72c1242 (patch)
tree9ee3d5a83624ba29fe3ca102752720b9bd63750f /x11-wm
parentx11-wm/xpra: migrate to PEP517. (diff)
downloadgentoo-68e45f8e359cda963c67c7e2755effcbb72c1242.tar.gz
gentoo-68e45f8e359cda963c67c7e2755effcbb72c1242.tar.bz2
gentoo-68e45f8e359cda963c67c7e2755effcbb72c1242.zip
x11-wm/xpra: sync the live ebuild with 4.4.6-r1.
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/files/xpra-9999-tests.patch34
-rw-r--r--x11-wm/xpra/xpra-9999.ebuild17
2 files changed, 11 insertions, 40 deletions
diff --git a/x11-wm/xpra/files/xpra-9999-tests.patch b/x11-wm/xpra/files/xpra-9999-tests.patch
deleted file mode 100644
index 746966577dcd..000000000000
--- a/x11-wm/xpra/files/xpra-9999-tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 79573c7f1241225922bee992f2caaf730cfbe3ac Mon Sep 17 00:00:00 2001
-From: totaam <antoine@xpra.org>
-Date: Sun, 9 Oct 2022 21:37:39 +0700
-Subject: [PATCH 3/3] Revert "don't use GLib directly"
-
-This reverts commit bc8bf26c44d1b151d709232460483f5432f79f5b.
----
- xpra/server/mixins/child_command_server.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/xpra/server/mixins/child_command_server.py b/xpra/server/mixins/child_command_server.py
-index 8dea3c1f7..1c2a60e27 100644
---- a/xpra/server/mixins/child_command_server.py
-+++ b/xpra/server/mixins/child_command_server.py
-@@ -11,6 +11,8 @@ import os.path
- from time import monotonic
- from subprocess import Popen
-
-+from gi.repository import GLib
-+
- from xpra.platform.features import COMMAND_SIGNALS
- from xpra.child_reaper import getChildReaper, reaper_cleanup
- from xpra.os_util import (
-@@ -72,7 +74,7 @@ class ChildCommandServer(StubServerMixin):
- #even if __init__ is called multiple times:
- if not getattr(self, "late_start_requested", False):
- self.late_start_requested = True
-- self.idle_add(self.late_start)
-+ GLib.idle_add(self.late_start)
-
- def late_start(self):
- def do_late_start():
---
-2.38.0
diff --git a/x11-wm/xpra/xpra-9999.ebuild b/x11-wm/xpra/xpra-9999.ebuild
index bc63326e1601..09e2d5b2a699 100644
--- a/x11-wm/xpra/xpra-9999.ebuild
+++ b/x11-wm/xpra/xpra-9999.ebuild
@@ -12,11 +12,11 @@ else
fi
PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=yes
-DISTUTILS_USE_SETUPTOOLS=no
DISTUTILS_EXT=1
-inherit xdg xdg-utils distutils-r1 tmpfiles udev
+inherit xdg xdg-utils distutils-r1 multibuild prefix tmpfiles udev
DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
HOMEPAGE="https://xpra.org/"
@@ -118,15 +118,12 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${PN}-9999-xdummy.patch
- "${FILESDIR}"/${PN}-9999-tests.patch
)
python_prepare_all() {
distutils-r1_python_prepare_all
- # FIXME: There are hardcoded paths all over the place but the following
- # double-prefixes some files under /etc. Looks tricky to fix. :(
- #hprefixify $(find -type f \( -name "*.py" -o -name "*.conf" \))
+ hprefixify xpra/scripts/config.py
sed -r -e "/\bdoc_dir =/s:/${PN}/\":/${PF}/html\":" \
-i setup.py || die
@@ -196,6 +193,14 @@ python_test() {
python_install_all() {
distutils-r1_python_prepare_all
+ # Switching to PEP517 gives /usr/etc. Previously, setup.py hardcodes
+ # if root_prefix.endswith("/usr"):
+ # root_prefix = root_prefix[:-4]
+ # But now setuptools uses data/* to represent out-of-sitedir files.
+ # The upstream hack no longer works. We are on our own.
+
+ mv -v "${ED}"/usr/etc "${ED}"/ || die
+
# Move udev dir to the right place if necessary.
if use udev; then
local dir=$(get_udevdir)