summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorEgor Martynov <martynovegorOF@yandex.ru>2023-04-10 19:45:06 +0700
committerSam James <sam@gentoo.org>2023-05-02 20:26:38 +0100
commite2e00e1f66e5dba2de1575b5782c052915b59c2a (patch)
tree712368638a147485d7a620f8e35cd13d5a13a50f /x11-wm
parentgnome-base/gvfs: Stabilize 1.50.4 x86, #905517 (diff)
downloadgentoo-e2e00e1f66e5dba2de1575b5782c052915b59c2a.tar.gz
gentoo-e2e00e1f66e5dba2de1575b5782c052915b59c2a.tar.bz2
gentoo-e2e00e1f66e5dba2de1575b5782c052915b59c2a.zip
x11-wm/qtile: fix sandbox violations on wayland
Closes: https://bugs.gentoo.org/904063 Signed-off-by: Egor Martynov <martynovegorOF@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/30537 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/qtile-0.21.0-r1.ebuild5
-rw-r--r--x11-wm/qtile/qtile-0.22.1-r1.ebuild5
-rw-r--r--x11-wm/qtile/qtile-0.22.1.ebuild5
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild5
4 files changed, 20 insertions, 0 deletions
diff --git a/x11-wm/qtile/qtile-0.21.0-r1.ebuild b/x11-wm/qtile/qtile-0.21.0-r1.ebuild
index 5e44902284db..b5911d3ce314 100644
--- a/x11-wm/qtile/qtile-0.21.0-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.21.0-r1.ebuild
@@ -58,6 +58,11 @@ python_test() {
epytest -p no:xdist || die "Tests failed with ${EPYTHON}"
}
+python_compile() {
+ export CFFI_TMPDIR=${T}
+ distutils-r1_python_compile
+}
+
python_install_all() {
local DOCS=( CHANGELOG README.rst )
distutils-r1_python_install_all
diff --git a/x11-wm/qtile/qtile-0.22.1-r1.ebuild b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
index 865019a7d76b..8f096ebbbaa8 100644
--- a/x11-wm/qtile/qtile-0.22.1-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.22.1-r1.ebuild
@@ -92,6 +92,11 @@ python_test() {
epytest -p no:xdist --backend=x11 $(usev wayland '--backend=wayland') || die "Tests failed with ${EPYTHON}"
}
+python_compile() {
+ export CFFI_TMPDIR=${T}
+ distutils-r1_python_compile
+}
+
python_install_all() {
local DOCS=( CHANGELOG README.rst )
distutils-r1_python_install_all
diff --git a/x11-wm/qtile/qtile-0.22.1.ebuild b/x11-wm/qtile/qtile-0.22.1.ebuild
index a51a99123343..c3d5540283f9 100644
--- a/x11-wm/qtile/qtile-0.22.1.ebuild
+++ b/x11-wm/qtile/qtile-0.22.1.ebuild
@@ -64,6 +64,11 @@ python_test() {
epytest -p no:xdist || die "Tests failed with ${EPYTHON}"
}
+python_compile() {
+ export CFFI_TMPDIR=${T}
+ distutils-r1_python_compile
+}
+
python_install_all() {
local DOCS=( CHANGELOG README.rst )
distutils-r1_python_install_all
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index 4133df21f1c7..db0c8d80ec74 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -89,6 +89,11 @@ python_test() {
epytest -p no:xdist --backend=x11 $(usev wayland '--backend=wayland') || die "Tests failed with ${EPYTHON}"
}
+python_compile() {
+ export CFFI_TMPDIR=${T}
+ distutils-r1_python_compile
+}
+
python_install_all() {
local DOCS=( CHANGELOG README.rst )
distutils-r1_python_install_all