summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 07:07:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:27 +0100
commit097049339962993673d88b4919d7e66b35b9d694 (patch)
tree79797dca8e650948896cd61fb7405f04fd1e670d /xfce-base
parentdev-python/easy-thumbnails: Bump to 2.8.5 (diff)
downloadgentoo-097049339962993673d88b4919d7e66b35b9d694.tar.gz
gentoo-097049339962993673d88b4919d7e66b35b9d694.tar.bz2
gentoo-097049339962993673d88b4919d7e66b35b9d694.zip
xfce-base/libxfce4windowing: Bump to 4.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4windowing/Manifest1
-rw-r--r--xfce-base/libxfce4windowing/libxfce4windowing-4.19.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/xfce-base/libxfce4windowing/Manifest b/xfce-base/libxfce4windowing/Manifest
index ebe4b6e4f26c..c35db5b91d10 100644
--- a/xfce-base/libxfce4windowing/Manifest
+++ b/xfce-base/libxfce4windowing/Manifest
@@ -1 +1,2 @@
DIST libxfce4windowing-4.19.0.tar.bz2 442774 BLAKE2B 8d0a64d07d1535f74d3767c47d2513b481502a8d2b259572fb22d25cb3ab07409c00014922ebe5222c2637792e57d2edfb94e7a028965ea076be52e098a8ed0e SHA512 c1dbbf243158239c96f2d3db4fb556dca72db7c885b6288653e45fa74cb22b5af2a997a7c7ac1ead203078de958a6dbec77a86826c867156266c341384e97f9d
+DIST libxfce4windowing-4.19.1.tar.bz2 452748 BLAKE2B 0fbf8ec5bb1d1857dfbe2851ef25a63dca57315c9f9dd5e3d870ae86c5fa054e3f4915d7cef1c98a5ac909ff29e8ad47b5b2754d1c8b2199320ee4a5efcf2eae SHA512 4666ff3a0142f584fb62cff8e6271a73bc3da8f1cd6dad629e3075a5a2552f54d56abb44bc6d9b2c1b4a1c8ed131bd6aa875714191cffd28958a2edf09a90729
diff --git a/xfce-base/libxfce4windowing/libxfce4windowing-4.19.1.ebuild b/xfce-base/libxfce4windowing/libxfce4windowing-4.19.1.ebuild
new file mode 100644
index 000000000000..18933d2987ad
--- /dev/null
+++ b/xfce-base/libxfce4windowing/libxfce4windowing-4.19.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://gitlab.xfce.org/xfce/libxfce4windowing/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+introspection wayland X"
+
+DEPEND="
+ >=dev-libs/glib-2.68.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?]
+ >=x11-libs/gdk-pixbuf-2.40.0[introspection?]
+ wayland? (
+ >=x11-libs/gtk+-3.24.0:3[wayland]
+ >=dev-libs/wayland-1.15
+ )
+ X? (
+ >=x11-libs/gtk+-3.24.0:3[X]
+ >=x11-libs/libwnck-3.14:3
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ wayland? (
+ >=dev-util/wayland-scanner-1.15
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable wayland gdk-wayland)
+ $(use_enable wayland wayland-scanner)
+ $(use_enable wayland wayland-client)
+ $(use_enable X libwnck)
+ $(use_enable X gdk-x11)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}