summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 18:32:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 18:49:41 +0100
commit5a2809dbe61158783fa3b3abab6f1ee76f6a1469 (patch)
tree8404d8afedf2aeb9f361470de85579ff7b451d29 /xfce-extra
parentxfce-extra/xfce4-eyes-plugin: Bump to 4.6.1 (diff)
downloadgentoo-5a2809dbe61158783fa3b3abab6f1ee76f6a1469.tar.gz
gentoo-5a2809dbe61158783fa3b3abab6f1ee76f6a1469.tar.bz2
gentoo-5a2809dbe61158783fa3b3abab6f1ee76f6a1469.zip
xfce-extra/xfce4-fsguard-plugin: Bump to 1.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-fsguard-plugin/Manifest b/xfce-extra/xfce4-fsguard-plugin/Manifest
index c127c5f2e513..0d6695b63e7b 100644
--- a/xfce-extra/xfce4-fsguard-plugin/Manifest
+++ b/xfce-extra/xfce4-fsguard-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-fsguard-plugin-1.1.3.tar.bz2 409310 BLAKE2B 6ad78241e49a667a7a9a2ab98daf74badd564b2aa20235f93abe80c9d30daf9b463392b2fbe044758e08975200f727eb78c9111b87c472c7bec9208f466f0c1b SHA512 4115a86a6ba38f8283752bb45527dac03b66ba3fb9d708391d9d98d9ecc97169ecbdfc515a01ad2ee2915144037e07ea1f9c8e9b831d47deba6e7c86d0f8563b
+DIST xfce4-fsguard-plugin-1.1.4.tar.bz2 468762 BLAKE2B e8e8576612baedc36816dda0720925562cef07290db0201ff935baa63e453821162e10332b7c03ce5d6451dd7142d13d190547b121bd8f8918bcf8292124b3f2 SHA512 844708aebbf7e0561ad1895f6c901a734bcfedfa217c4ab1c78e904069f639c3266a69dccee8a69529bd94c925de874ab2ff1746f8927d4445908d1bd4dff78c
diff --git a/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.4.ebuild b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.4.ebuild
new file mode 100644
index 000000000000..6980d176897a
--- /dev/null
+++ b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A filesystem guard plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-fsguard-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-fsguard-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}