summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-10 13:40:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 20:14:02 +0200
commitc463f0e6964286aea0efc0074aa27a2601f549d2 (patch)
treef326834c31832ed28c935ba92ca190fed65e5951 /xfce-extra
parentvirtual/dist-kernel: Bump to 6.1.105 (diff)
downloadgentoo-c463f0e6964286aea0efc0074aa27a2601f549d2.tar.gz
gentoo-c463f0e6964286aea0efc0074aa27a2601f549d2.tar.bz2
gentoo-c463f0e6964286aea0efc0074aa27a2601f549d2.zip
xfce-extra/xfce4-smartbookmark-plugin: bump EAPI, remove empty IUSE
- rework DEPENDs to be more like xfce-base/xfce4-session - add gitlab to HOMEPAGE Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/38055 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..5c9a9afe7965
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin/
+ https://gitlab.xfce.org/panel-plugins/xfce4-smartbookmark-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # substitute default bugtracker
+ sed -i -e '/bugs/s:bugs\.debian:bugs.gentoo:' src/smartbookmark.c || die
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}