summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-5.0.1.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index b5393ffd381b..c0016b803370 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,2 +1 @@
-DIST tekore-5.0.1.gh.tar.gz 261087 BLAKE2B a5355f6604dee84cbd169b7de2574f5a46b5651784f9aa8201b56127dbac239c58548c8a1ae9928ba3da19a6275cf7f3eb4139d5a0402bb99548bfae051d89a3 SHA512 6c49f6434434d68845aa5e7de8cb2b2075921b9c27f36f2e5d8a8e0ea14996e7cf96e44bd2bc4081278c329e157c30c4aa95192b14d99df8bf607bce10cdd6a8
DIST tekore-5.1.0.gh.tar.gz 261207 BLAKE2B 7c52fe1bd0a29da10d846d04543ccca5770e2e5682e5f816fd6ac56c0f351ba2374662187ab71350cf2e8c298175c045c1d35b4512f529b67aef11a4a80a8f15 SHA512 13c8853c707ee2234632e8f051b22df67935afa26c5f4c684728031a78ded88b9d71fff44093d9765a2287ecb5613b8b6b792727d632bce234d89a8668d86ca4
diff --git a/dev-python/tekore/tekore-5.0.1.ebuild b/dev-python/tekore/tekore-5.0.1.ebuild
deleted file mode 100644
index e364947bea00..000000000000
--- a/dev-python/tekore/tekore-5.0.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spotify Web API client"
-HOMEPAGE="
- https://tekore.readthedocs.io/
- https://github.com/felix-hilden/tekore/
- https://pypi.org/project/tekore/
-"
-SRC_URI="
- https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND="
- <dev-python/httpx-0.25[${PYTHON_USEDEP}]
- >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( readme.rst )
-
-distutils_enable_tests pytest
-# TODO: package sphinx_codeautolink
-# distutils_enable_sphinx docs/src \
-# dev-python/sphinx-rtd-theme \
-# dev-python/sphinx-tabs \
-# dev-python/sphinx-autodoc-typehints
-
-EPYTEST_DESELECT=(
- # Internet
- tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
- # these tests use calls specific to pydantic-2
- # TODO: reselect when we can depend on >=pydantic-2
- tests/model.py::TestModel::test_enum_in_model
- tests/model.py::TestModel::test_unknown_attribute_ignored
-)