summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/sequoia-sq/files/sequoia-sq-0.27.0-Explicitly-drop-the-Box.patch20
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.27.0.ebuild6
2 files changed, 25 insertions, 1 deletions
diff --git a/app-crypt/sequoia-sq/files/sequoia-sq-0.27.0-Explicitly-drop-the-Box.patch b/app-crypt/sequoia-sq/files/sequoia-sq-0.27.0-Explicitly-drop-the-Box.patch
new file mode 100644
index 000000000000..3488ac62d6ad
--- /dev/null
+++ b/app-crypt/sequoia-sq/files/sequoia-sq-0.27.0-Explicitly-drop-the-Box.patch
@@ -0,0 +1,20 @@
+From 7916f90421ecb9a75e32f0284459bcc9a3fd02b0 Mon Sep 17 00:00:00 2001
+From: Justus Winter <justus@sequoia-pgp.org>
+Date: Wed, 19 Oct 2022 14:55:58 +0200
+Subject: [PATCH] openpgp: Explicitly drop the Box.
+
+ - Appeases the compiler that now complains about the unused result.
+--- a/openpgp/src/crypto/mem.rs
++++ b/openpgp/src/crypto/mem.rs
+@@ -159,7 +159,7 @@ impl Drop for Protected {
+ unsafe {
+ let len = self.len();
+ memsec::memzero(self.as_mut().as_mut_ptr(), len);
+- Box::from_raw(self.0);
++ drop(Box::from_raw(self.0));
+ }
+ }
+ }
+--
+2.38.2
+
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.27.0.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.27.0.ebuild
index 4b5c805418cd..2beff104d292 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.27.0.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.27.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Generate base ebuild via
@@ -412,6 +412,10 @@ KEYWORDS="amd64 ~ppc64"
S="${WORKDIR}/${PN}-v${PV}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.27.0-Explicitly-drop-the-Box.patch
+)
+
QA_FLAGS_IGNORED="usr/bin/sq"
COMMON_DEPEND="