summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r1.ebuild (renamed from app-admin/webapp-config/webapp-config-1.55.ebuild)10
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild10
2 files changed, 16 insertions, 4 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.55.ebuild b/app-admin/webapp-config/webapp-config-1.55-r1.ebuild
index b83d9fcd994a..871ffb75c6a7 100644
--- a/app-admin/webapp-config/webapp-config-1.55.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.55-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,13 @@ IUSE="+portage"
DEPEND="app-text/xmlto
sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+RDEPEND="
+ portage? (
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ )"
python_prepare_all() {
distutils-r1_python_prepare_all
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 409c9b0d9b1b..08cda6204783 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,7 +26,13 @@ IUSE="+portage"
DEPEND="app-text/xmlto
sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+RDEPEND="
+ portage? (
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ )"
python_prepare_all() {
distutils-r1_python_prepare_all