summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.7.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 45e8d110fecc..2cd55daf0c85 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.35.23.gh.tar.gz 2819656 BLAKE2B 6e9d20410344f075ce12bfc8c0a49941a
DIST aws-cli-1.36.4.gh.tar.gz 2825870 BLAKE2B 3a13a50077087633972c0eb908e0116e432f0036871f4d5a5e2429ea86dfc0c5d40a87e0950c02bc7622fb0e56b9a3ee9fc8ee9a6a1ed8ae17728bf479401d13 SHA512 735a228d52b525cfc4a9a403ad8364bfb9c558ba86daf6966743126eb21de6d0f49d76fd21d9c7a0fd29f229b4b71e0778d4b1ccd0b2e27b0c794f1e11cd6c83
DIST aws-cli-1.36.5.gh.tar.gz 2826720 BLAKE2B fc1fae0f6983c635e27a98747dc9cdf7b43dceedc52104923e4ad1272664b09a28939db876cd235206e83925cf77bdd872de82660ddd286ba6e8ede273b5a704 SHA512 009ff8306302f47c7ea1f5eff93265ce1334e799fb541b0a96759495790e30a0164501e09b45fd72a58aa828d1a67fed4061b4e65b4dd1f84722b49b0ba43f9e
DIST aws-cli-1.36.6.gh.tar.gz 2827814 BLAKE2B 23089b5c996a298b1a9cc529701f9ad25d5794b81e1bfdf952db829dd3d57ec2c5229f81fe071d6ef4e9d050b55766d3abb38a40ff10bb91dbb882c39dd2c68a SHA512 a02725703fe7cab1b55683a1cd9b7fcb4ca9fe7deedd7b867b52a9164af6522fe25be8da6ee1858708ad3a9e20f134155b70cc87d8c87d5df167336dc8539de0
+DIST aws-cli-1.36.7.gh.tar.gz 2830849 BLAKE2B 97dc3fe17c64e241d8bee007664e5c10feea87f799f6c4659883da1f85fb12610d46e77ed58cb884656a3b2ff89dd51e0f7d2bcc5ac8947b45c517a06d5f815e SHA512 bf8cfc09c0c3948d778d5ad9cdb5638f7b3ea7ac34c9e63e98a46fa06c651bc5798076a35229506f272b6b0160165bbea69beea5497989b70b6d2d2bc86334c8
diff --git a/app-admin/awscli/awscli-1.36.7.ebuild b/app-admin/awscli/awscli-1.36.7.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.7.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}