summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/bespin/bespin-0_p20140225-r1.ebuild38
-rw-r--r--x11-themes/bespin/bespin-0_p20140225.ebuild56
2 files changed, 38 insertions, 56 deletions
diff --git a/x11-themes/bespin/bespin-0_p20140225-r1.ebuild b/x11-themes/bespin/bespin-0_p20140225-r1.ebuild
new file mode 100644
index 000000000000..25c4af068b1f
--- /dev/null
+++ b/x11-themes/bespin/bespin-0_p20140225-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Very configurable Qt4 style derived from the Oxygen project"
+HOMEPAGE="http://cloudcity.sourceforge.net/"
+SRC_URI="https://sourceforge.net/code-snapshots/svn/c/cl/cloudcity/code/cloudcity-code-1712.zip"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qt3support:4
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ x11-libs/libX11
+ x11-libs/libXrender
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/cloudcity-code-1712"
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
diff --git a/x11-themes/bespin/bespin-0_p20140225.ebuild b/x11-themes/bespin/bespin-0_p20140225.ebuild
deleted file mode 100644
index 2cc9a3fe7bae..000000000000
--- a/x11-themes/bespin/bespin-0_p20140225.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-KDE_REQUIRED="optional"
-KDE_SCM="svn"
-
-inherit kde4-base qmake-utils
-
-if [[ $PV != *9999 ]]; then
- REV="1712"
- S="${WORKDIR}/cloudcity-code-${REV}"
- SRC_URI="https://sourceforge.net/code-snapshots/svn/c/cl/cloudcity/code/cloudcity-code-${REV}.zip"
- KEYWORDS="~amd64 ~x86"
-else
- ESVN_REPO_URI="https://svn.code.sf.net/p/cloudcity/code/"
- KEYWORDS=""
-fi
-
-DESCRIPTION="Very configurable Qt4 style derived from the Oxygen project"
-HOMEPAGE="http://cloudcity.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="debug"
-
-RDEPEND="
- dev-qt/qt3support:4
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- x11-libs/libX11
- x11-libs/libXrender
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
-"
-
-src_prepare() {
- # bug #542976
- sed -e "s/kworkspace//" -i XBar/CMakeLists.txt || die
-
- kde4-base_src_prepare
-}
-
-src_configure() {
- eqmake4
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-}