summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiodns/aiodns-3.0.0-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
index fd48e2ce2eb3..7602b45d3ebb 100644
--- a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
+++ b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
@@ -22,9 +22,18 @@ RESTRICT="test"
RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
PATCHES=(
# https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
"${FILESDIR}/${P}-py3.10-tests.patch"
)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet changed, https://github.com/saghul/aiodns/issues/107
+ tests.py::DNSTest::test_query_bad_chars
+ )
+
+ epytest tests.py
+}