summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-wm/hyprland/hyprland-0.25.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/gui-wm/hyprland/hyprland-0.25.0.ebuild b/gui-wm/hyprland/hyprland-0.25.0.ebuild
index bf62573979c1..aff592df7d8c 100644
--- a/gui-wm/hyprland/hyprland-0.25.0.ebuild
+++ b/gui-wm/hyprland/hyprland-0.25.0.ebuild
@@ -54,10 +54,14 @@ BDEPEND="
"
src_prepare() {
- STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
+ if [[ $(tc-is-gcc) ]]; then
+ STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
- if ! [[ ${STDLIBVER} -ge 12 ]]; then
- die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ if ! [[ ${STDLIBVER} -ge 12 ]]; then
+ die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ fi
+ elif [[ $(clang-major-version) -lt 16 ]]; then
+ die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
fi
if use video_cards_nvidia; then