summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/geeqie/files/geeqie-2.0.1-doc_option.patch81
-rw-r--r--media-gfx/geeqie/geeqie-2.0.1-r1.ebuild (renamed from media-gfx/geeqie/geeqie-2.0.1.ebuild)28
-rw-r--r--media-gfx/geeqie/geeqie-9999.ebuild32
-rw-r--r--media-gfx/geeqie/metadata.xml4
4 files changed, 118 insertions, 27 deletions
diff --git a/media-gfx/geeqie/files/geeqie-2.0.1-doc_option.patch b/media-gfx/geeqie/files/geeqie-2.0.1-doc_option.patch
new file mode 100644
index 000000000000..e12ab036b4c9
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-2.0.1-doc_option.patch
@@ -0,0 +1,81 @@
+diff -Naur geeqie-2.0.1.orig/doc/meson.build geeqie-2.0.1/doc/meson.build
+--- geeqie-2.0.1.orig/doc/meson.build 2022-08-12 11:32:25.000000000 +0200
++++ geeqie-2.0.1/doc/meson.build 2022-10-18 16:26:33.776338232 +0200
+@@ -20,21 +20,16 @@
+ guideindex_ln = join_paths(destdir, 'index.html')
+
+ # Not-found notification already handled by ../meson.build
+-if gnome_doc_tool.found()
++if not get_option('doc').disabled() and gnome_doc_tool.found()
+ run_command(gnome_doc_tool, 'html', '-o', destdir, '-p', iconsdir, guideindex_xml, check : false)
+ run_command(find_program('ln'), '-s', '-f', guideindex_html, guideindex_ln, check : false)
+ endif
+
+ install_subdir(destdir, install_dir : helpdir, exclude_directories : 'lua-api/latex')
+
+-doxygen = find_program('doxygen', required : false)
+-if doxygen.found()
++if not get_option('doc').disabled() and doxygen.found()
+ srcdir = join_paths(meson.source_root())
+ destdir = join_paths(meson.build_root(), 'doc', 'html', 'lua-api')
+
+ run_command(find_program('create-doxygen-lua-api.sh'), srcdir, destdir, check : false)
+-
+- summary({'lua-api' : ['lua-api help file created:', true]}, section : 'Documentation', bool_yn : true)
+-else
+- summary({'lua-api' : ['doxygen not found - lua-api help file created:', false]}, section : 'Documentation', bool_yn : true)
+ endif
+diff -Naur geeqie-2.0.1.orig/meson.build geeqie-2.0.1/meson.build
+--- geeqie-2.0.1.orig/meson.build 2022-08-12 11:32:25.000000000 +0200
++++ geeqie-2.0.1/meson.build 2022-10-18 16:25:38.063273607 +0200
+@@ -62,12 +62,6 @@
+ # External programs
+ gdk_pixbuf_csource = find_program('gdk-pixbuf-csource', required : true)
+ glib_genmarshal = find_program('glib-genmarshal', required : true)
+-gnome_doc_tool = find_program('yelp-build', required : false)
+-if gnome_doc_tool.found()
+- summary({'help' : ['Help files created:', true]}, section : 'Documentation', bool_yn : true)
+-else
+- summary({'help' : ['yelp-build not found - Help files created:', false]}, section : 'Documentation', bool_yn : true)
+-endif
+
+ debug = get_option('debug')
+
+@@ -138,6 +132,26 @@
+ gtk_dep = dependency('gtk+-3.0', version : '>=3.22', required: true)
+ glib_dep = dependency('glib-2.0', version : '>=2.52', required: true)
+
++#option = get_option('doc')
++if not get_option('doc').disabled()
++ gnome_doc_tool = find_program('yelp-build', required : false)
++ if gnome_doc_tool.found()
++ summary({'help' : ['Help files created:', true]}, section : 'Documentation', bool_yn : true)
++ else
++ summary({'help' : ['yelp-build not found - Help files created:', false]}, section : 'Documentation', bool_yn : true)
++ endif
++
++ doxygen = find_program('doxygen', required : false)
++ if doxygen.found()
++ summary({'lua-api' : ['lua-api help file created:', true]}, section : 'Documentation', bool_yn : true)
++ else
++ summary({'lua-api' : ['doxygen not found - lua-api help file created:', false]}, section : 'Documentation', bool_yn : true)
++ endif
++else
++ summary({'help' : ['disabled - Help files created:', false]}, section : 'Documentation', bool_yn : true)
++ summary({'lua-api' : ['disabled - lua-api help file created:', false]}, section : 'Documentation', bool_yn : true)
++endif
++
+ libarchive_dep = []
+ req_version = '>=3.4.0'
+ option = get_option('archive')
+diff -Naur geeqie-2.0.1.orig/meson_options.txt geeqie-2.0.1/meson_options.txt
+--- geeqie-2.0.1.orig/meson_options.txt 2022-08-12 11:32:25.000000000 +0200
++++ geeqie-2.0.1/meson_options.txt 2022-10-18 16:25:38.063273607 +0200
+@@ -26,6 +26,7 @@
+ option('archive', type : 'feature', value : 'auto', description : 'archive files e.g. zip, gz')
+ option('cms', type : 'feature', value : 'auto', description : 'color management system')
+ option('djvu', type : 'feature', value : 'auto', description : 'djvu')
++option('doc', type : 'feature', value : 'auto', description : 'doc')
+ option('exiv2', type : 'feature', value : 'auto', description : 'exiv2')
+ option('videothumbnailer', type : 'feature', value : 'auto', description : 'video thumbnailer')
+ option('gps-map', type : 'feature', value : 'auto', description : 'gps map')
diff --git a/media-gfx/geeqie/geeqie-2.0.1.ebuild b/media-gfx/geeqie/geeqie-2.0.1-r1.ebuild
index 0e4c3907aa5c..8a99ae4480da 100644
--- a/media-gfx/geeqie/geeqie-2.0.1.ebuild
+++ b/media-gfx/geeqie/geeqie-2.0.1-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/BestImageViewer/${PN}/releases/download/v${PV}/${P}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug doc djvu exif ffmpegthumbnailer gpu-accel heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
+IUSE="debug doc djvu exif ffmpegthumbnailer heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
RDEPEND="gnome-extra/zenity
virtual/libintl
@@ -23,7 +23,6 @@ RDEPEND="gnome-extra/zenity
doc? ( app-text/yelp-tools )
exif? ( >=media-gfx/exiv2-0.17:=[xmp?] )
ffmpegthumbnailer? ( media-video/ffmpegthumbnailer )
- gpu-accel? ( media-libs/clutter-gtk )
heif? ( >=media-libs/libheif-1.3.2 )
jpeg2k? ( >=media-libs/openjpeg-2.3.0:2 )
jpeg? ( media-libs/libjpeg-turbo:= )
@@ -31,7 +30,8 @@ RDEPEND="gnome-extra/zenity
lcms? ( media-libs/lcms:2 )
lua? ( ${LUA_DEPS}
doc? ( app-doc/doxygen ) )
- map? ( media-libs/libchamplain:0.12 )
+ map? ( media-libs/clutter-gtk
+ media-libs/libchamplain:0.12[gtk] )
pdf? ( >=app-text/poppler-0.62[cairo] )
raw? ( >=media-libs/libraw-0.20 )
spell? ( app-text/gspell )
@@ -46,13 +46,18 @@ BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- map? ( gpu-accel )"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
PATCHES=(
- "${FILESDIR}/${P}-allow_xxdi.patch"
+ "${FILESDIR}"/${P}-allow_xxdi.patch
+ "${FILESDIR}"/${P}-doc_option.patch
)
+pkg_setup() {
+ # Do not require setting LUA_SINGLE_TARGET if lua is not used
+ use lua && lua-single_pkg_setup
+}
+
src_prepare() {
default
@@ -65,22 +70,23 @@ src_configure() {
-Dgq_helpdir="share/doc/${PF}"
-Dgq_htmldir="share/doc/${PF}/html"
$(meson_use debug)
- $(meson_feature zip archive)
- $(meson_feature lcms cms)
$(meson_feature djvu)
+ $(meson_feature doc)
$(meson_feature exif exiv2)
$(meson_feature ffmpegthumbnailer videothumbnailer)
- $(meson_feature gpu-accel gps-map)
$(meson_feature heif)
- $(meson_feature jpeg2k j2k)
$(meson_feature jpeg)
+ $(meson_feature jpeg2k j2k)
$(meson_feature jpegxl)
- $(meson_feature raw libraw)
+ $(meson_feature lcms cms)
$(meson_feature lua)
+ $(meson_feature map gps-map)
$(meson_feature pdf)
+ $(meson_feature raw libraw)
$(meson_feature spell)
$(meson_feature tiff)
$(meson_feature webp)
+ $(meson_feature zip archive)
)
meson_src_configure
diff --git a/media-gfx/geeqie/geeqie-9999.ebuild b/media-gfx/geeqie/geeqie-9999.ebuild
index 2c4b54ad1991..5a49b5e60c1c 100644
--- a/media-gfx/geeqie/geeqie-9999.ebuild
+++ b/media-gfx/geeqie/geeqie-9999.ebuild
@@ -15,7 +15,7 @@ EGIT_REPO_URI="https://github.com/BestImageViewer/geeqie.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc djvu exif ffmpegthumbnailer gpu-accel heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
+IUSE="debug doc djvu exif ffmpegthumbnailer heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
RDEPEND="gnome-extra/zenity
virtual/libintl
@@ -24,7 +24,6 @@ RDEPEND="gnome-extra/zenity
doc? ( app-text/yelp-tools )
exif? ( >=media-gfx/exiv2-0.17:=[xmp?] )
ffmpegthumbnailer? ( media-video/ffmpegthumbnailer )
- gpu-accel? ( media-libs/clutter-gtk )
heif? ( >=media-libs/libheif-1.3.2 )
jpeg2k? ( >=media-libs/openjpeg-2.3.0:2 )
jpeg? ( media-libs/libjpeg-turbo:= )
@@ -32,7 +31,8 @@ RDEPEND="gnome-extra/zenity
lcms? ( media-libs/lcms:2 )
lua? ( ${LUA_DEPS}
doc? ( app-doc/doxygen ) )
- map? ( media-libs/libchamplain:0.12 )
+ map? ( media-libs/clutter-gtk
+ media-libs/libchamplain:0.12[gtk] )
pdf? ( >=app-text/poppler-0.62[cairo] )
raw? ( >=media-libs/libraw-0.20 )
spell? ( app-text/gspell )
@@ -47,13 +47,17 @@ BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- map? ( gpu-accel )"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}/${PN}-2.0.1-allow_xxdi.patch"
)
+pkg_setup() {
+ # Do not require setting LUA_SINGLE_TARGET if lua is not used
+ use lua && lua-single_pkg_setup
+}
+
src_prepare() {
default
@@ -66,22 +70,23 @@ src_configure() {
-Dgq_helpdir="share/doc/${PF}"
-Dgq_htmldir="share/doc/${PF}/html"
$(meson_use debug)
- $(meson_feature zip archive)
- $(meson_feature lcms cms)
$(meson_feature djvu)
+ $(meson_feature doc)
$(meson_feature exif exiv2)
$(meson_feature ffmpegthumbnailer videothumbnailer)
- $(meson_feature gpu-accel gps-map)
$(meson_feature heif)
- $(meson_feature jpeg2k j2k)
$(meson_feature jpeg)
+ $(meson_feature jpeg2k j2k)
$(meson_feature jpegxl)
- $(meson_feature raw libraw)
+ $(meson_feature lcms cms)
$(meson_feature lua)
+ $(meson_feature map gps-map)
$(meson_feature pdf)
+ $(meson_feature raw libraw)
$(meson_feature spell)
$(meson_feature tiff)
$(meson_feature webp)
+ $(meson_feature zip archive)
)
meson_src_configure
@@ -100,10 +105,9 @@ pkg_postinst() {
xdg_pkg_postinst
optfeature "Camera import and tethered photography plugins" media-gfx/gphoto2
- optfeature "Export JPEG plugin" media-gfx/exiv2
optfeature "Lens ID plugin" media-libs/exiftool
- optfeature "Image crop plugin" "media-gfx/exiv2 media-libs/exiftool media-gfx/imagemagick"
- optfeature "Image rotate plugin (JPEG)" "media-gfx/exiv2 media-gfx/fbida"
- optfeature "Image rotate plugin (TIFF/PNG)" "media-gfx/exiv2 media-gfx/imagemagick"
+ optfeature "Image crop plugin" "media-libs/exiftool media-gfx/imagemagick"
+ optfeature "Image rotate plugin (JPEG)" media-gfx/fbida
+ optfeature "Image rotate plugin (TIFF/PNG)" media-gfx/imagemagick
optfeature "Print preview functionality" app-text/evince
}
diff --git a/media-gfx/geeqie/metadata.xml b/media-gfx/geeqie/metadata.xml
index 684ebb361389..3ee5d0faec97 100644
--- a/media-gfx/geeqie/metadata.xml
+++ b/media-gfx/geeqie/metadata.xml
@@ -10,8 +10,8 @@
<flag name="ffmpegthumbnailer">Enable video thumbnail support with <pkg>media-video/ffmpegthumbnailer</pkg></flag>
<flag name="gpu-accel">Enable GPU acceleration support - experimental</flag>
<flag name="gtk3">Link against <pkg>x11-libs/gtk+</pkg>:3 instead of <pkg>x11-libs/gtk+</pkg>:2</flag>
- <flag name="heif">Enable support for ISO/IEC 23008-12:2017 HEIF files</flag>
+ <flag name="heif">Enable support for ISO/IEC 23008-12:2017 HEIF/HEIC image format using <pkg>media-libs/libheif</pkg></flag>
<flag name="jpegxl">Enable support for JPEG XL image format</flag>
- <flag name="map">Enable items map display - experimental</flag>
+ <flag name="map">Enable items GPS map display</flag>
</use>
</pkgmetadata>