summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aws-sam-translator/Manifest1
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.84.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index c614cc09379e..f4035cf2e1d5 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1 +1,2 @@
DIST serverless-application-model-1.83.0.gh.tar.gz 5423374 BLAKE2B faa11adf7b6ec9df3eb625a77c2f6242b4c9fe170be8926f90da1cab94dc2c018e2ba7fc53dffec63756e68deebe7bdb22853d9e67e84e8e696399b81ed4b648 SHA512 f2bd8ce766894118107dd6cac245ae47b9fd819f9cb04a0c7d176ab3ec4f56bebbfc9c4e371f2b1db372c594a15d3c6871195b5aba06712a9f2408a51284cba1
+DIST serverless-application-model-1.84.0.gh.tar.gz 5467750 BLAKE2B 386abc362020a9f3da6e040d0d31c1da9ee24311d779dabf9deb84ca5fd2abc655daf78f0303884e81fee1eb4a14f30f42e768475b85ad389d10625452fc9703 SHA512 4d771dccb9ca2d5f03c7e04f3dcf40c06b7a23cc5eb9a59d1fc2ae76abb944d469127131b1995edb9d44c90ef637b21fe65af42df2adf559fd06af92016ff2e5
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.84.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.84.0.ebuild
new file mode 100644
index 000000000000..166699d76ae6
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.84.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+MY_P=serverless-application-model-${PV}
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ <dev-python/pydantic-3[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # so much noise...
+ sed -i -e '/log_cli/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AWS_DEFAULT_REGION=us-east-1
+ epytest -o addopts= -o filterwarnings= \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}