summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/distutils-r1.eclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 85e94bd569e4..ba0226f8fed3 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -85,10 +85,14 @@ esac
# are:
#
# - no -- do not add the dependency (pure distutils package)
+#
# - bdepend -- add it to BDEPEND (the default)
+#
# - rdepend -- add it to BDEPEND+RDEPEND (e.g. when using pkg_resources)
+#
# - pyproject.toml -- use pyproject2setuptools to install a project
# using pyproject.toml (flit, poetry...)
+#
# - manual -- do not add the dependency and suppress the checks
# (assumes you will take care of doing it correctly)
#