summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/cpuburn')
-rw-r--r--app-benchmarks/cpuburn/Manifest1
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild32
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a.ebuild30
-rw-r--r--app-benchmarks/cpuburn/files/01-variables.patch40
-rw-r--r--app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch7
-rw-r--r--app-benchmarks/cpuburn/metadata.xml10
6 files changed, 120 insertions, 0 deletions
diff --git a/app-benchmarks/cpuburn/Manifest b/app-benchmarks/cpuburn/Manifest
new file mode 100644
index 000000000000..7cf8fcf1b57f
--- /dev/null
+++ b/app-benchmarks/cpuburn/Manifest
@@ -0,0 +1 @@
+DIST cpuburn-1.4a.tar.gz 9277 SHA256 eb191ce9bfbf453d30c218c3419573df102a3588f96c4a43686c84bb9da4bed6 SHA512 db84cabe70af0b6b3579c746f6df08c268b7145c9521fc609ce5b4cfd497dbb0639e52ab55f34110cff297ec23cf1413db28c6bff4e6f81a69722626886df7ce WHIRLPOOL e119aeaf3453357125fb0f203fdbd0bb68f52479213d6cf6462fcaf53636cb4a13b16f5350cc4b9a382ff9ccc362535f362f6b5b78165c683dcd432e281c7b46
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
new file mode 100644
index 000000000000..6d06937ccd3b
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PV/./_}"
+
+DESCRIPTION="Designed to heavily load CPU chips [testing purposes]"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+#SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz -> ${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/01-variables.patch
+ use amd64 && append-flags -m32 #65719
+ tc-export CC
+}
+
+src_install() {
+ dodoc Design README
+ dobin burn{BX,K6,K7,MMX,P5,P6}
+}
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
new file mode 100644
index 000000000000..30ebdbef6930
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PV/./_}"
+
+DESCRIPTION="Designed to heavily load CPU chips [testing purposes]"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+#SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz -> ${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ use amd64 && append-flags -m32 #65719
+ tc-export CC
+}
+
+src_install() {
+ dodoc Design README
+ dobin burn{BX,K6,K7,MMX,P5,P6}
+}
diff --git a/app-benchmarks/cpuburn/files/01-variables.patch b/app-benchmarks/cpuburn/files/01-variables.patch
new file mode 100644
index 000000000000..3e8b666c29ec
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/01-variables.patch
@@ -0,0 +1,40 @@
+--- cpuburn-1.4a.orig/burnK7.S
++++ cpuburn-1.4a/burnK7.S
+@@ -74,6 +74,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ .fill 64
+ half: .long 0x7fffffff,0
+--- cpuburn-1.4a.orig/burnP5.S
++++ cpuburn-1.4a/burnP5.S
+@@ -77,6 +77,7 @@ crunch:
+ #else
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0xffffffff,0x3fdfffff
+ one: .long 0xffffffff,0x3fefffff
+--- cpuburn-1.4a.orig/burnP6.S
++++ cpuburn-1.4a/burnP6.S
+@@ -69,6 +69,7 @@ int_exit: # error abort
+ push %eax # *BSD syscall
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
+--- cpuburn-1.4a.orig/burnK6.S
++++ cpuburn-1.4a/burnK6.S
+@@ -68,6 +68,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
diff --git a/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
new file mode 100644
index 000000000000..97b8836c0af4
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
@@ -0,0 +1,7 @@
+--- Makefile.orig 2001-06-16 05:39:17.000000000 +0200
++++ Makefile 2010-10-12 20:31:38.000000000 +0200
+@@ -1,3 +1,3 @@
+ all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
+ .S:
+- gcc -s -nostdlib -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -nostdlib -o $@ $<
diff --git a/app-benchmarks/cpuburn/metadata.xml b/app-benchmarks/cpuburn/metadata.xml
new file mode 100644
index 000000000000..afc8cb4d2030
--- /dev/null
+++ b/app-benchmarks/cpuburn/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+ <longdescription>
+ CPUBurn is the ultimate stability testing tool for overclockers. The
+ program heats up any x86 CPU to the maximum possible operating
+ temperature that is achievable by using ordinary software.
+ </longdescription>
+</pkgmetadata>