summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/cfssl/cfssl-1.4.1-r1.ebuild (renamed from app-crypt/cfssl/cfssl-1.4.1.ebuild)8
-rw-r--r--app-crypt/cfssl/cfssl-1.6.4-r1.ebuild (renamed from app-crypt/cfssl/cfssl-1.6.4.ebuild)8
2 files changed, 12 insertions, 4 deletions
diff --git a/app-crypt/cfssl/cfssl-1.4.1.ebuild b/app-crypt/cfssl/cfssl-1.4.1-r1.ebuild
index 7541ce49e832..d9a5facf5a3f 100644
--- a/app-crypt/cfssl/cfssl-1.4.1.ebuild
+++ b/app-crypt/cfssl/cfssl-1.4.1-r1.ebuild
@@ -14,8 +14,6 @@ SLOT="0"
KEYWORDS="amd64"
IUSE="hardened"
-RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
-
PATCHES=(
"${FILESDIR}/${P}-build-fix.patch"
)
@@ -30,4 +28,10 @@ src_compile() {
src_install() {
dobin bin/*
dodoc CHANGELOG README.md
+ mv -iv "${ED}"/usr/bin/mkbundle{,.cfssl} || die
+}
+
+pkg_postinst() {
+ ewarn "Please note that mkbundle is renamed to mkbundle.cfssl, to avoid"
+ ewarn "collision with mkbundle in dev-lang/mono"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.4.ebuild b/app-crypt/cfssl/cfssl-1.6.4-r1.ebuild
index 3d244721ab37..83786737696b 100644
--- a/app-crypt/cfssl/cfssl-1.6.4.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.4-r1.ebuild
@@ -14,8 +14,6 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="hardened"
-RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
-
PATCHES=(
"${FILESDIR}/${PN}-1.4.1-build-fix.patch"
)
@@ -30,4 +28,10 @@ src_compile() {
src_install() {
dobin bin/*
dodoc CHANGELOG README.md
+ mv -iv "${ED}"/usr/bin/mkbundle{,.cfssl} || die
+}
+
+pkg_postinst() {
+ ewarn "Please note that mkbundle is renamed to mkbundle.cfssl, to avoid"
+ ewarn "collision with mkbundle in dev-lang/mono"
}