summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/spice-0.14.3-r1.ebuild3
-rw-r--r--app-emulation/spice/spice-9999.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/spice/spice-0.14.3-r1.ebuild b/app-emulation/spice/spice-0.14.3-r1.ebuild
index 175926c76fbf..1a6bb7e5ea35 100644
--- a/app-emulation/spice/spice-0.14.3-r1.ebuild
+++ b/app-emulation/spice/spice-0.14.3-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://www.spice-space.org/download/releases/spice-server/${P}.tar.bz2
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="libressl lz4 sasl smartcard static-libs gstreamer"
+IUSE="libressl lz4 sasl smartcard static-libs gstreamer test"
# the libspice-server only uses the headers of libcacard
RDEPEND="
@@ -77,6 +77,7 @@ src_configure() {
$(use_enable lz4)
$(use_with sasl)
$(use_enable smartcard)
+ $(use_enable test tests)
--enable-gstreamer=$(usex gstreamer "1.0" "no")
--disable-celt051
"
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index a7cd1fa64454..4b0c15f247e3 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice.git"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="gstreamer libressl lz4 opus sasl smartcard static-libs"
+IUSE="gstreamer libressl lz4 opus sasl smartcard static-libs test"
# the libspice-server only uses the headers of libcacard
RDEPEND="
@@ -73,6 +73,7 @@ src_configure() {
$(meson_use sasl)
$(meson_feature opus)
$(meson_feature smartcard)
+ $(meson_use test tests)
-Dmanual=false
-Dtests=false
)