summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pysmssend/pysmssend-1.48.ebuild')
-rw-r--r--app-misc/pysmssend/pysmssend-1.48.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/pysmssend/pysmssend-1.48.ebuild b/app-misc/pysmssend/pysmssend-1.48.ebuild
new file mode 100644
index 000000000000..08381ddd3d8f
--- /dev/null
+++ b/app-misc/pysmssend/pysmssend-1.48.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python Application for sending sms over multiple ISPs"
+HOMEPAGE="http://pysmssend.silverarrow.org/"
+SRC_URI="http://pysmssend.silverarrow.org/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt4"
+
+DEPEND=">dev-python/mechanize-0.1.7b
+ qt4? ( dev-python/PyQt4[X] )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="pysmssendmod"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ distutils_src_install
+ if use qt4; then
+ insinto /usr/share/${PN}/Icons || die "insinto failed"
+ doins Icons/* || die "doins failed"
+ doicon Icons/pysmssend.png || die "doicon failed"
+ dobin pysmssend pysmssendcmd || die "failed to create executables"
+ make_desktop_entry pysmssend pySMSsend pysmssend \
+ "Applications;Network" || die "make_desktop_entry failed"
+ else
+ dobin pysmssendcmd || die "failed to create executable"
+ dosym pysmssendcmd /usr/bin/pysmssend || die "dosym failed"
+ fi
+ dodoc README AUTHORS TODO || die "dodoc failed"
+}