summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/todo/todo-2.10-r1.ebuild')
-rw-r--r--app-misc/todo/todo-2.10-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/todo/todo-2.10-r1.ebuild b/app-misc/todo/todo-2.10-r1.ebuild
new file mode 100644
index 000000000000..5fa2cd242a92
--- /dev/null
+++ b/app-misc/todo/todo-2.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com/"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+PATCHES=( "${FILESDIR}/${P}-fix-bash-completion.patch" )
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+src_test() {
+ make test || die "tests failed"
+}
+
+src_install() {
+ dobin "${PN}.sh"
+ dosym "/usr/bin/${PN}.sh" "/usr/bin/${PN}txt"
+ newbashcomp "${PN}_completion" "${PN}.sh"
+ bashcomp_alias "${PN}.sh" "${PN}txt"
+ einstalldocs
+}