summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cedilla')
-rw-r--r--app-text/cedilla/Manifest1
-rw-r--r--app-text/cedilla/cedilla-0.6.ebuild34
-rw-r--r--app-text/cedilla/files/cedilla-gentoo-r1.patch22
-rw-r--r--app-text/cedilla/files/cedilla-gentoo.patch22
-rw-r--r--app-text/cedilla/metadata.xml12
5 files changed, 91 insertions, 0 deletions
diff --git a/app-text/cedilla/Manifest b/app-text/cedilla/Manifest
new file mode 100644
index 000000000000..613b0f29f49b
--- /dev/null
+++ b/app-text/cedilla/Manifest
@@ -0,0 +1 @@
+DIST cedilla-0.6.tar.gz 130676 SHA256 c5840c3e125fab29af844540239dfb475b59c6ecd67270736898608de743df43 SHA512 95d98fd4ab95b48023f635d61133ea1a8138a797cd1c414da0d4907531eb067ac147e8d612a528373da425d37fee7c1139dc7f0019308938c096e37caebf4e38 WHIRLPOOL fff84c8c7e2e1c1452dfbaf6bf58d97d405c1f56269cadb0d852ba7c183dec0b73906dfa62ca732e84a7eeb472d4ee2d66adebdd1fc224e56a5c45792a5f1117
diff --git a/app-text/cedilla/cedilla-0.6.ebuild b/app-text/cedilla/cedilla-0.6.ebuild
new file mode 100644
index 000000000000..f9dc5040f2dd
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/cedilla-gentoo-r1.patch
+}
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed -i "s#${ED%/}##g" cedilla || die "sed failed"
+ newman cedilla.man cedilla.1
+ ./install-cedilla || die "Install failed."
+ dodoc NEWS README
+}
diff --git a/app-text/cedilla/files/cedilla-gentoo-r1.patch b/app-text/cedilla/files/cedilla-gentoo-r1.patch
new file mode 100644
index 000000000000..af9c92a8ee7b
--- /dev/null
+++ b/app-text/cedilla/files/cedilla-gentoo-r1.patch
@@ -0,0 +1,22 @@
+diff -Naur cedilla-0.3.orig/cedilla-config cedilla-0.3/cedilla-config
+--- cedilla-0.3.orig/cedilla-config 2002-02-18 11:53:39.000000000 +0000
++++ cedilla-0.3/cedilla-config 2003-06-02 20:36:44.000000000 +0000
+@@ -2,14 +2,14 @@
+ CLISP=/usr/bin/clisp
+
+ # Where the main Cedilla binary will be installed
+-BINDIR=/usr/bin
++BINDIR=${ED%/}/usr/bin
+
+ # Where the cedilla-config.lisp file lives
+-ETCDIR=/etc
++ETCDIR=${ED%/}/etc
+
+ # Where Cedilla's FASL files will be kept
+-LIBDIR=/usr/lib/cedilla
++LIBDIR=${ED%/}/usr/lib/cedilla
+
+ # Where the cedilla(1) manual page will be installed
+-MANDIR=/usr/share/man/man1
++MANDIR=${ED%/}/usr/share/man/man1
+
diff --git a/app-text/cedilla/files/cedilla-gentoo.patch b/app-text/cedilla/files/cedilla-gentoo.patch
new file mode 100644
index 000000000000..20646d76b9fd
--- /dev/null
+++ b/app-text/cedilla/files/cedilla-gentoo.patch
@@ -0,0 +1,22 @@
+diff -Naur cedilla-0.3.orig/cedilla-config cedilla-0.3/cedilla-config
+--- cedilla-0.3.orig/cedilla-config 2002-02-18 11:53:39.000000000 +0000
++++ cedilla-0.3/cedilla-config 2003-06-02 20:36:44.000000000 +0000
+@@ -2,14 +2,14 @@
+ CLISP=/usr/bin/clisp
+
+ # Where the main Cedilla binary will be installed
+-BINDIR=/usr/bin
++BINDIR=${D}/usr/bin
+
+ # Where the cedilla-config.lisp file lives
+-ETCDIR=/etc
++ETCDIR=${D}/etc
+
+ # Where Cedilla's FASL files will be kept
+-LIBDIR=/usr/lib/cedilla
++LIBDIR=${D}/usr/lib/cedilla
+
+ # Where the cedilla(1) manual page will be installed
+-MANDIR=/usr/share/man/man1
++MANDIR=${D}/usr/share/man/man1
+
diff --git a/app-text/cedilla/metadata.xml b/app-text/cedilla/metadata.xml
new file mode 100644
index 000000000000..9dd77881a9b9
--- /dev/null
+++ b/app-text/cedilla/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+</pkgmetadata>