summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/hd2u')
-rw-r--r--app-text/hd2u/Manifest1
-rw-r--r--app-text/hd2u/files/hd2u-1.0.0-build.patch25
-rw-r--r--app-text/hd2u/files/hd2u-1.0.3-build.patch25
-rw-r--r--app-text/hd2u/hd2u-1.0.3.ebuild25
-rw-r--r--app-text/hd2u/metadata.xml5
5 files changed, 81 insertions, 0 deletions
diff --git a/app-text/hd2u/Manifest b/app-text/hd2u/Manifest
new file mode 100644
index 000000000000..e0426f88f6a6
--- /dev/null
+++ b/app-text/hd2u/Manifest
@@ -0,0 +1 @@
+DIST hd2u-1.0.3.tgz 60024 SHA256 3c9269e4aa188ddfb1ccadbb9a1906d87f6cbb60b8a2ce71cc6c9f2082ccc890 SHA512 d354964f0ad5392315767b96438d843a5f1d6afe78da5b0c5ea65a3b0b2a61beabff3ecac89df81b9271a14ca443f23dfffeb51815e02b724ad287e42fc2d6cc WHIRLPOOL 36ef7e7beaa27129a12c9dbb7ecbc62c048d2a4db87c68ccb8a2ba5442d9e2bfab6db6a636204331b3c213af45635f2bd6eaa33fd89c60473f684420c423ae1b
diff --git a/app-text/hd2u/files/hd2u-1.0.0-build.patch b/app-text/hd2u/files/hd2u-1.0.0-build.patch
new file mode 100644
index 000000000000..66b32bbc17c7
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.0-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 328016c..f8cc6aa 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+ rebuild: cleanall $(TARGET)
+
+@@ -59,9 +59,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/files/hd2u-1.0.3-build.patch b/app-text/hd2u/files/hd2u-1.0.3-build.patch
new file mode 100644
index 000000000000..de788e8aa774
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.3-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 2a67b3c..651323d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,7 +42,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+
+ all-optimized: $(TARGET)-optimized
+@@ -98,9 +98,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/hd2u-1.0.3.ebuild b/app-text/hd2u/hd2u-1.0.3.ebuild
new file mode 100644
index 000000000000..d7a191df3a5f
--- /dev/null
+++ b/app-text/hd2u/hd2u-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Dos2Unix like text file converter"
+HOMEPAGE="http://www.megaloman.com/~hany/software/hd2u/"
+SRC_URI="http://www.megaloman.com/~hany/_data/hd2u/${P}.tgz"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ !app-text/dos2unix"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
diff --git a/app-text/hd2u/metadata.xml b/app-text/hd2u/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-text/hd2u/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>