summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pspdftool')
-rw-r--r--app-text/pspdftool/Manifest1
-rw-r--r--app-text/pspdftool/metadata.xml14
-rw-r--r--app-text/pspdftool/pspdftool-0.03.ebuild40
-rw-r--r--app-text/pspdftool/pspdftool-9999.ebuild38
4 files changed, 93 insertions, 0 deletions
diff --git a/app-text/pspdftool/Manifest b/app-text/pspdftool/Manifest
new file mode 100644
index 000000000000..a6595acd2550
--- /dev/null
+++ b/app-text/pspdftool/Manifest
@@ -0,0 +1 @@
+DIST pspdftool-0.03.tar.bz2 129936 SHA256 18e932c35221861909528c6a358f404720ce911a7a139bcf6376eb6fc2fde610 SHA512 8e621719c59f79f7201e8221a851e85d11573fa1895a64ab5e77382fa1103004f70a38f98928a8ce4b5795ce89ac3e4a7a5eade772959e26e49d6db9cc7fe7ea WHIRLPOOL 1db9fb41af6a70dc6de4799199b657038755a938dc89872a9ccb6e3a7fb22bfca8cb83befe8471ea3f65cf4e74113e96b4fc67f7d2e88fc51f27d6f04b99f9d0
diff --git a/app-text/pspdftool/metadata.xml b/app-text/pspdftool/metadata.xml
new file mode 100644
index 000000000000..0b14fb209f4a
--- /dev/null
+++ b/app-text/pspdftool/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>miska@gentoo.org</email>
+ <name>Michal Hrušecký</name>
+ </maintainer>
+ <longdescription lang="en">
+Pspdftool is a tool for preprinting preparation of documents. It supports PostScript and PDF files and allows users do several transformations (for example rotation, scale, miror ...) and pages selections.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pspdftool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pspdftool/pspdftool-0.03.ebuild b/app-text/pspdftool/pspdftool-0.03.ebuild
new file mode 100644
index 000000000000..1b36b92b5667
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-0.03.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+ESVN_REPO_URI="https://pspdftool.svn.sourceforge.net/svnroot/pspdftool/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="http://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}
diff --git a/app-text/pspdftool/pspdftool-9999.ebuild b/app-text/pspdftool/pspdftool-9999.ebuild
new file mode 100644
index 000000000000..7b39916051c3
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+ESVN_REPO_URI="https://pspdftool.svn.sourceforge.net/svnroot/pspdftool/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="http://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}