summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/rqlite/rqlite-8.36.6.ebuild')
-rw-r--r--dev-db/rqlite/rqlite-8.36.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/rqlite/rqlite-8.36.6.ebuild b/dev-db/rqlite/rqlite-8.36.6.ebuild
new file mode 100644
index 000000000000..aa2a8696a9ae
--- /dev/null
+++ b/dev-db/rqlite/rqlite-8.36.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+EGIT_COMMIT=5bd095af56c904ea270315f3d0d9b182516db5f0
+
+DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
+HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
+SRC_URI="https://github.com/rqlite/rqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+LICENSE+=" Apache-2.0 BSD CC0-1.0 MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ ln -sv ../vendor ./ || die
+ default
+}
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ ego install \
+ -ldflags="-X main.version=v${PV}
+ -X main.branch=master
+ -X main.commit=${EGIT_COMMIT}
+ -X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
+ ./cmd/... || die
+}
+
+src_test() {
+ GOBIN="${S}/bin" \
+ ego test ./... || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r *.md DOC
+}