summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashed-storage/hashed-storage-0.5.10.ebuild')
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.5.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.5.10.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.5.10.ebuild
new file mode 100644
index 000000000000..5831b8fb092f
--- /dev/null
+++ b/dev-haskell/hashed-storage/hashed-storage-0.5.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Hashed file storage support code"
+HOMEPAGE="http://hackage.haskell.org/package/hashed-storage"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ dev-haskell/dataenc:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ =dev-haskell/mmap-0.5*:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND=">=dev-haskell/cabal-1.6
+ test? (
+ >=dev-haskell/quickcheck-2.3
+ dev-haskell/test-framework[profile?]
+ dev-haskell/test-framework-hunit[profile?]
+ dev-haskell/test-framework-quickcheck2[profile?]
+ dev-haskell/zip-archive[profile?]
+ )
+ ${RDEPEND}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test)
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}/usr/bin/hashed-storage-test"
+}