summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/logict')
-rw-r--r--dev-haskell/logict/Manifest2
-rw-r--r--dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch20
-rw-r--r--dev-haskell/logict/logict-0.6.0.1.ebuild27
-rw-r--r--dev-haskell/logict/logict-0.6.0.2.ebuild26
-rw-r--r--dev-haskell/logict/metadata.xml12
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-haskell/logict/Manifest b/dev-haskell/logict/Manifest
new file mode 100644
index 000000000000..bff5a6798529
--- /dev/null
+++ b/dev-haskell/logict/Manifest
@@ -0,0 +1,2 @@
+DIST logict-0.6.0.1.tar.gz 5288 SHA256 e2f6e0877ce9323d9401f55e68351e039135060e9d77c1b6b758177abacdf66b SHA512 ebed60ef3d977cdd6038482942447c66ceecd5c5e2ccbd801b510bf06c0dd7ef6f45b7af738ea3b149b58b4ad730ca286c31625eda4880dc71ba09b96e234774 WHIRLPOOL d54435f56fb8b78d7d327bab985f785e59a44b3ee8d1ffdabdbc6dc29435d68811471d74d6f5a8f7dcc7eca9b198e467f425e0d2392ffe0aa2c11e21093f7d75
+DIST logict-0.6.0.2.tar.gz 5370 SHA256 1182b68e8d00279460c7fb9b8284bf129805c07754c678b2a8de5a6d768e161e SHA512 dfb72d006d9b7a5f0d7447d956ea0c3d083e200a616efc4b34fafa0582c2dc7e9369156cf4f51a472b97f7afb6167030edeb84e77c7bc410bfe58a44f0ac4fc4 WHIRLPOOL 395780835fa55373db28b5d006ef260f4ff82f12d4aeeb1bd5bc83fe9a06f2613624a7ffc5e619420c2232b8abe6554b9488c73e71a6c5a016e2a89fc2b85eec
diff --git a/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
new file mode 100644
index 000000000000..7e2449494e96
--- /dev/null
+++ b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
@@ -0,0 +1,20 @@
+--- logict-0.5.0-orig/Control/Monad/Logic.hs 2011-07-30 02:23:36.000000000 +1000
++++ logict-0.5.0/Control/Monad/Logic.hs 2012-01-06 20:53:00.424125711 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses #-}
++{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses, CPP #-}
+
+ -------------------------------------------------------------------------
+ -- |
+@@ -155,6 +155,11 @@
+ where
+ ssk a fk = return $ Just (a, (lift fk >>= reflect))
+
++#if !MIN_VERSION_mtl(2,0,0)
++instance F.Foldable Identity where
++ foldMap f (Identity x) = f x
++#endif
++
+ instance (Monad m, F.Foldable m) => F.Foldable (LogicT m) where
+ foldMap f m = F.fold $ unLogicT m (liftM . mappend . f) (return mempty)
+
diff --git a/dev-haskell/logict/logict-0.6.0.1.ebuild b/dev-haskell/logict/logict-0.6.0.1.ebuild
new file mode 100644
index 000000000000..02398340ab24
--- /dev/null
+++ b/dev-haskell/logict/logict-0.6.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A backtracking logic-programming monad"
+HOMEPAGE="http://code.haskell.org/~dolio/logict"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-0"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.0-ghc-6.12.patch")
diff --git a/dev-haskell/logict/logict-0.6.0.2.ebuild b/dev-haskell/logict/logict-0.6.0.2.ebuild
new file mode 100644
index 000000000000..80210f3b86a5
--- /dev/null
+++ b/dev-haskell/logict/logict-0.6.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A backtracking logic-programming monad"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+"
diff --git a/dev-haskell/logict/metadata.xml b/dev-haskell/logict/metadata.xml
new file mode 100644
index 000000000000..80f0869f09c7
--- /dev/null
+++ b/dev-haskell/logict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A continuation-based, backtracking, logic programming monad.
+ An adaptation of the two-continuation implementation found
+ in the paper &quot;Backtracking, Interleaving, and Terminating
+ Monad Transformers&quot; available here:
+ &lt;http://okmij.org/ftp/papers/LogicT.pdf&gt;
+ </longdescription>
+</pkgmetadata>