summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild')
-rw-r--r--dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild b/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild
new file mode 100644
index 000000000000..1bda1539d99f
--- /dev/null
+++ b/dev-haskell/network-conduit/network-conduit-1.0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -network-bytestring
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Stream socket data using conduits"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-network-bytestring
+}