summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/strict')
-rw-r--r--dev-haskell/strict/Manifest1
-rw-r--r--dev-haskell/strict/metadata.xml10
-rw-r--r--dev-haskell/strict/strict-0.3.2.ebuild23
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/strict/Manifest b/dev-haskell/strict/Manifest
new file mode 100644
index 000000000000..20f8cb48b1a4
--- /dev/null
+++ b/dev-haskell/strict/Manifest
@@ -0,0 +1 @@
+DIST strict-0.3.2.tar.gz 3948 SHA256 2cd35a67938db635a87617d9576d5df0158b581e8e5694f07487c0f4b1549221 SHA512 ca27ee2b557669c409c0417b2005ceb612ad95040fd4a798535cdbc83b8b7a51a36bb66bc2e7bff04b5b965313894a51910a274d67a891530ed119c831bcd686 WHIRLPOOL c5a0d874f18926839a7298a640afc2244eb5c7c72cbc0b3499d2d9b3244315d2227142927a10da59275e1e29653fb671066180a587ccb9a8af29de867c0f4066
diff --git a/dev-haskell/strict/metadata.xml b/dev-haskell/strict/metadata.xml
new file mode 100644
index 000000000000..1d05a51d5598
--- /dev/null
+++ b/dev-haskell/strict/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides strict versions of some standard Haskell data
+ types (pairs, Maybe and Either). It also contains strict IO
+ operations.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/strict/strict-0.3.2.ebuild b/dev-haskell/strict/strict-0.3.2.ebuild
new file mode 100644
index 000000000000..7a62d5cfc09e
--- /dev/null
+++ b/dev-haskell/strict/strict-0.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Strict data types and String IO"
+HOMEPAGE="http://www.cse.unsw.edu.au/~rl/code/strict.html"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"