summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
index c94b15abb363..50dd03400a4a 100644
--- a/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
@@ -215,8 +215,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."