summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/popt')
-rw-r--r--dev-libs/popt/Manifest1
-rw-r--r--dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch12
-rw-r--r--dev-libs/popt/metadata.xml5
-rw-r--r--dev-libs/popt/popt-1.16-r1.ebuild37
-rw-r--r--dev-libs/popt/popt-1.16-r2.ebuild36
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/popt/Manifest b/dev-libs/popt/Manifest
new file mode 100644
index 000000000000..b7a63bae47e1
--- /dev/null
+++ b/dev-libs/popt/Manifest
@@ -0,0 +1 @@
+DIST popt-1.16.tar.gz 702769 SHA256 e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8 SHA512 bae2dd4e5d682ef023fdc77ae60c4aad01a3a576d45af9d78d22490c11e410e60edda37ede171920746d4ae0d5de3c060d15cecfd41ba75b727a811be828d694 WHIRLPOOL 0f6ffe7dcab6dcca718f0c79a30d620d0cc2583d2c1018e4eb2357d7594df6b282c68a9e9b14f5c00731ef3abb0a39c98c3f8fa5a7331137702aea34682c7b4c
diff --git a/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch b/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch
new file mode 100644
index 000000000000..32e1bb353037
--- /dev/null
+++ b/dev-libs/popt/files/fix-popt-pkgconfig-libdir.patch
@@ -0,0 +1,12 @@
+diff -u popt-1.16.orig/Makefile.in popt-1.16/Makefile.in
+--- popt-1.16.orig/Makefile.in 2010-05-04 16:55:59.000000000 -0400
++++ popt-1.16/Makefile.in 2010-12-23 22:45:42.843131000 -0500
+@@ -370,7 +370,7 @@
+ libpopt_la_SOURCES = popt.c poptparse.c poptconfig.c popthelp.c poptint.c
+ libpopt_la_LDFLAGS = -no-undefined @LTLIBINTL@ @LTLIBICONV@ \
+ $(am__append_1)
+-pkgconfigdir = $(prefix)/lib/pkgconfig
++pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = popt.pc
+ man_MANS = popt.3
+ BUILT_SOURCES = popt.pc # popt.lcd
diff --git a/dev-libs/popt/metadata.xml b/dev-libs/popt/metadata.xml
new file mode 100644
index 000000000000..bee9f9ae6f02
--- /dev/null
+++ b/dev-libs/popt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+</pkgmetadata>
diff --git a/dev-libs/popt/popt-1.16-r1.ebuild b/dev-libs/popt/popt-1.16-r1.ebuild
new file mode 100644
index 000000000000..1f6c1ae77251
--- /dev/null
+++ b/dev-libs/popt/popt-1.16-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-popt-pkgconfig-libdir.patch #349558
+ sed -i -e 's:lt-test1:test1:' testit.sh || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README || die
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-libs/popt/popt-1.16-r2.ebuild b/dev-libs/popt/popt-1.16-r2.ebuild
new file mode 100644
index 000000000000..044b9b18e3da
--- /dev/null
+++ b/dev-libs/popt/popt-1.16-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-popt-pkgconfig-libdir.patch #349558
+ sed -i -e 's:lt-test1:test1:' testit.sh || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable nls)
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ prune_libtool_files --all
+}