summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luasec/luasec-0.4.1.ebuild')
-rw-r--r--dev-lua/luasec/luasec-0.4.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/luasec/luasec-0.4.1.ebuild b/dev-lua/luasec/luasec-0.4.1.ebuild
new file mode 100644
index 000000000000..bb1ce8ea1896
--- /dev/null
+++ b/dev-lua/luasec/luasec-0.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
+HOMEPAGE="http://www.inf.puc-rio.br/~brunoos/luasec/"
+SRC_URI="http://www.inf.puc-rio.br/~brunoos/luasec/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0[deprecated]
+ dev-lua/luasocket
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s#^LUAPATH=.*#LUAPATH=$(pkg-config --variable INSTALL_LMOD lua)#" "${S}/Makefile"
+ sed -i -e "s#^LUACPATH=.*#LUACPATH=$(pkg-config --variable INSTALL_CMOD lua)#" "${S}/Makefile"
+ epatch "${FILESDIR}/${PN}-0.4_Makefile.patch"
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ linux \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}