summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlbuild/files/installbin.patch')
-rw-r--r--dev-ml/ocamlbuild/files/installbin.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/files/installbin.patch b/dev-ml/ocamlbuild/files/installbin.patch
new file mode 100644
index 000000000000..e7bd2cfcfa7d
--- /dev/null
+++ b/dev-ml/ocamlbuild/files/installbin.patch
@@ -0,0 +1,13 @@
+Index: ocamlbuild-0.9.1/Makefile
+===================================================================
+--- ocamlbuild-0.9.1.orig/Makefile
++++ ocamlbuild-0.9.1/Makefile
+@@ -202,7 +202,7 @@ beforedepend:: src/ocamlbuild_config.ml
+ install-bin-byte:
+ mkdir -p $(INSTALL_BINDIR)
+ $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild.byte$(EXE)
+-ifeq ($(OCAML_NATIVE), true)
++ifneq ($(OCAML_NATIVE), true)
+ $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild$(EXE)
+ endif
+