summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uunf/uunf-13.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-13.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-13.0.0.ebuild b/dev-ml/uunf/uunf-13.0.0.ebuild
new file mode 100644
index 000000000000..fcccf0d182d6
--- /dev/null
+++ b/dev-ml/uunf/uunf-13.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ || die
+}