summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-3.3.6.ebuild89
-rw-r--r--dev-python/astroid/astroid-3.3.7.ebuild89
-rw-r--r--dev-python/astroid/astroid-3.3.8.ebuild4
4 files changed, 2 insertions, 182 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index c082aedbebf1..707709d23497 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1 @@
-DIST astroid-3.3.6.gh.tar.gz 466233 BLAKE2B 6b8bebeb7f56009d6ea7749f911a309e6cd2a0a7bac7ade1ea91ca74bc157f048c3652a50321a72c961670cb8dcc8f584bd39ef8a2d82408b4be27c8efcbdb58 SHA512 7ed2900cdf563cb761596cb816452e64be131c34d7ea7eedb27a5ceac4e588c3c675deba72bee17557c408c019e489c6f1e86772bdc235e2f1b048239b76c993
-DIST astroid-3.3.7.gh.tar.gz 466979 BLAKE2B 1f6abc37d1fd35eafc3bd6cebdc7611259cb6e77ff4c447d108ce1d88fa723a867c82eab2a93b9095bee033745a2fe3e81441e940d9c7b82910d5d04c75c334c SHA512 1debf08f1707714ac23e024632a0f686020fe7e46fdd9e417586923b7ff5b393d2e106e6145b7580c8ffece728f3228d52f71ca0b52adbd8ad1c40102fc72bc8
DIST astroid-3.3.8.gh.tar.gz 467093 BLAKE2B 0f019e8569d7fff96d0c6e4025312d03ec518a3d7014b35bd381989d88b4ed4bb4c796597cbf6ee892ea25c03eeb9159e1f40791f20f9a27a0f8c2578d565a0c SHA512 b788815d07d6a9f5796a4e5d1c1d1df5ad9786c43b82c9f10719097bad01881c394352aaeada3171bfaf8fa72f1542efb1f75b88b8ea9164f96f4946654d00c6
diff --git a/dev-python/astroid/astroid-3.3.6.ebuild b/dev-python/astroid/astroid-3.3.6.ebuild
deleted file mode 100644
index 8e973999aca6..000000000000
--- a/dev-python/astroid/astroid-3.3.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/pylint-dev/astroid/
- https://pypi.org/project/astroid/
-"
-SRC_URI="
- https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# Version specified in pyproject.toml
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# dev-python/regex isn't available for pypy
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/regex[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # no clue why they're broken
- tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
- # pydantic-2?
- tests/brain/test_dataclasses.py::test_pydantic_field
- # requires urllib3 with bundled six (skipped with urllib3>=2)
- tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
- # hangs
- tests/test_nodes.py::AsStringTest::test_recursion_error_trapped
- # TODO
- tests/test_builder.py::BuilderTest::test_data_build_error_filename
- # numpy-2 (https://github.com/pylint-dev/astroid/issues/2442)
- tests/brain/numpy/test_core_einsumfunc.py::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_fromnumeric.py::BrainNumpyCoreFromNumericTest::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_multiarray.py::BrainNumpyCoreMultiarrayTest::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_datetime_astype_return
- tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_generic_types_are_subscriptables
- tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type
- tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type_tuple
- )
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- tests/test_transforms.py::TestTransforms::test_transform_aborted_if_recursion_limited
- )
- ;;
- python3.13)
- EPYTEST_DESELECT+=(
- # changes in py3.13.0b4
- # https://github.com/pylint-dev/astroid/issues/2478
- tests/test_nodes.py::AsStringTest::test_f_strings
- tests/test_nodes_lineno.py::TestLinenoColOffset::test_end_lineno_string
- )
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/astroid/astroid-3.3.7.ebuild b/dev-python/astroid/astroid-3.3.7.ebuild
deleted file mode 100644
index adfa5e854419..000000000000
--- a/dev-python/astroid/astroid-3.3.7.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/pylint-dev/astroid/
- https://pypi.org/project/astroid/
-"
-SRC_URI="
- https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# Version specified in pyproject.toml
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# dev-python/regex isn't available for pypy
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/regex[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # no clue why they're broken
- tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
- # pydantic-2?
- tests/brain/test_dataclasses.py::test_pydantic_field
- # requires urllib3 with bundled six (skipped with urllib3>=2)
- tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
- # hangs
- tests/test_nodes.py::AsStringTest::test_recursion_error_trapped
- # TODO
- tests/test_builder.py::BuilderTest::test_data_build_error_filename
- # numpy-2 (https://github.com/pylint-dev/astroid/issues/2442)
- tests/brain/numpy/test_core_einsumfunc.py::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_fromnumeric.py::BrainNumpyCoreFromNumericTest::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_multiarray.py::BrainNumpyCoreMultiarrayTest::test_numpy_function_calls_inferred_as_ndarray
- tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_datetime_astype_return
- tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_generic_types_are_subscriptables
- tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type
- tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type_tuple
- )
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- tests/test_transforms.py::TestTransforms::test_transform_aborted_if_recursion_limited
- )
- ;;
- python3.13)
- EPYTEST_DESELECT+=(
- # changes in py3.13.0b4
- # https://github.com/pylint-dev/astroid/issues/2478
- tests/test_nodes.py::AsStringTest::test_f_strings
- tests/test_nodes_lineno.py::TestLinenoColOffset::test_end_lineno_string
- )
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/astroid/astroid-3.3.8.ebuild b/dev-python/astroid/astroid-3.3.8.ebuild
index adfa5e854419..528cca0ef320 100644
--- a/dev-python/astroid/astroid-3.3.8.ebuild
+++ b/dev-python/astroid/astroid-3.3.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="LGPL-2.1+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# Version specified in pyproject.toml
RDEPEND="