summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2024.10.0.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 1b3565202075..6ff993aba195 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,2 +1 @@
-DIST filesystem_spec-2024.10.0.gh.tar.gz 415286 BLAKE2B 59e8a1457c528c350ef49da546ee8e15dc27031dde3c5b2ae4c97a7ec0a392010c8d1558c4a6569be07aebc272add9629c6e8e7fc7e392259bb5f72b47b65a3c SHA512 46542e494044e40110c3da879ec620daca15e3a18e3e0a318f0c98f18a08aa7c319fffdf396527e920f6bc5f17fbec5e4c2030ed6a9b8853720e513165dbc56d
DIST filesystem_spec-2024.12.0.gh.tar.gz 421670 BLAKE2B f6e6f2b478f89c9fbad6822149dc9a2b868fd2fee6edfbd532471b23d49248360170323e9454cc803c4096e62d8957e4ecaf1062bce3cdce005b39af94fdf52c SHA512 9e506da2c81a603350ecea7745b98fa38727bd0f176dc587dd570cab0e27650cd77ac061dce190d6b6372bb5dc4d5a0f3beb59b831a11a1392e178e6c94ab872
diff --git a/dev-python/fsspec/fsspec-2024.10.0.ebuild b/dev-python/fsspec/fsspec-2024.10.0.ebuild
deleted file mode 100644
index e06e223520d0..000000000000
--- a/dev-python/fsspec/fsspec-2024.10.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-# upstream removed tests in 2024.6.0
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-# Note: this package is not xdist-friendly
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
-}