summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hpack/hpack-4.1.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-4.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-4.1.0.ebuild b/dev-python/hpack/hpack-4.1.0.ebuild
new file mode 100644
index 000000000000..a7a8da6f2650
--- /dev/null
+++ b/dev-python/hpack/hpack-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/projects/hpack/en/latest/
+ https://github.com/python-hyper/hpack/
+ https://pypi.org/project/hpack/
+"
+# PyPI sdist is missing test fixtures, as of 4.0.0
+SRC_URI="
+ https://github.com/python-hyper/hpack/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest