summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest3
-rw-r--r--dev-python/hypothesis/hypothesis-6.123.17.ebuild104
-rw-r--r--dev-python/hypothesis/hypothesis-6.124.3.ebuild2
-rw-r--r--dev-python/hypothesis/hypothesis-6.125.2.ebuild (renamed from dev-python/hypothesis/hypothesis-6.124.7.ebuild)0
4 files changed, 2 insertions, 107 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c896091f61bd..a8cc8f322ab5 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,4 +1,3 @@
-DIST hypothesis-6.123.17.gh.tar.gz 9508250 BLAKE2B 494c41299a646856050889e2093dae477386c76ac3e57576698178a65cfe4b3bb7a2cfe19204904ae0ca8d25cf8d347389c7eb76b7d8ac046067fc4b11bd509f SHA512 73f2c2cd1bb9063d74448cfba0f85308398b52fcb0cd948a64b6396f698b914154a93b7afdf2b3c32a902f21f6a84996218572af700c35c518d9a41bbe6cae8f
DIST hypothesis-6.124.3.gh.tar.gz 9510786 BLAKE2B d4104ce7cbe009ce1e0d2d6fa04db8d5dda2db08f8dcdaea90d4a111cbcf71db53214a5b06a69ca40715a0999970e45293aad754dcfbd06c1a6e4e04700aee83 SHA512 898567b6e32b619892292c07e95ca57f671e9fcc6925dd560285147491fba72df5fe5c41a3642d3910961ef569cbce8790ea1100359e674f08f5b24522073184
-DIST hypothesis-6.124.7.gh.tar.gz 9507487 BLAKE2B d0160dedfd78443724a7388020fa093ba95e8621403f4fa69f04c324a5be8d49b51c3cae4cca488a86046818b6762a3f9703b1963186ae82daed2c8cdf0f8f70 SHA512 c9c699d830082ccfb056c42817592ad3736b3e1c2294bed889d9e581dc8d4b093a86a949b24e3fa842941daf18933c55c6a479cd6768c30cde0cecb94777a620
DIST hypothesis-6.124.9.gh.tar.gz 9507981 BLAKE2B 469448e2c97b0a798293d53d2ae1ea328c61c94245245b989a33a3520a903dbb6a4a468192dc7837dfe75bde5d9a010ffb7d4b8f16c7c8462bab8da4f183f310 SHA512 0c0f48a88a748d4bf1fc0763b4e464166536d4d16461f06a2090a2f5f54464730fff8eb7892ff60584c2135853aab7a56253db83dfd90a8e679fa3f37d4fb6a9
+DIST hypothesis-6.125.2.gh.tar.gz 9508767 BLAKE2B 2f356f9678c1c8a56dcc66c5f96fee3426860e541e30c52b9108769fbb4112f9f4d8c77a9b9acef045a52749dd9325155fa8790c023f05dbf58608531ec0f89e SHA512 c953eef644a3c3239c2d0ace3eb6c02c7c48bb37d8fba6c6429720c7ab4b42fd76f6e42ee94f543db8d224bfb6912ed5e64feb181c24207a403e307364618843
diff --git a/dev-python/hypothesis/hypothesis-6.123.17.ebuild b/dev-python/hypothesis/hypothesis-6.123.17.ebuild
deleted file mode 100644
index 3b81c426627d..000000000000
--- a/dev-python/hypothesis/hypothesis-6.123.17.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( pypy3 python3_{10..13} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 optfeature
-
-TAG=hypothesis-python-${PV}
-MY_P=hypothesis-${TAG}
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="
- https://github.com/HypothesisWorks/hypothesis/
- https://pypi.org/project/hypothesis/
-"
-SRC_URI="
- https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_P}/hypothesis-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="cli"
-
-RDEPEND="
- >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
- ' 3.9 3.10)
- cli? (
- $(python_gen_cond_dep '
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- ' "${CLI_COMPAT[@]}")
- )
-"
-BDEPEND="
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_test() {
- # subtests are broken by warnings from random plugins
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
- local -x HYPOTHESIS_NO_PLUGINS=1
-
- # NB: paths need to be relative to pytest.ini,
- # i.e. start with hypothesis-python/
- local EPYTEST_DESELECT=()
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # failing due to warnings from numpy/cython
- hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
- )
- ;;
- esac
-
- epytest -o filterwarnings= -p rerunfailures --reruns=5 \
- tests/cover tests/pytest tests/quality
-}
-
-src_install() {
- local HAD_CLI=
-
- distutils-r1_src_install
-
- if [[ ! ${HAD_CLI} ]]; then
- rm -r "${ED}/usr/bin" || die
- fi
-}
-
-python_install() {
- distutils-r1_python_install
- if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
- HAD_CLI=1
- else
- rm -r "${D}$(python_get_scriptdir)" || die
- fi
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}
diff --git a/dev-python/hypothesis/hypothesis-6.124.3.ebuild b/dev-python/hypothesis/hypothesis-6.124.3.ebuild
index 4486f30faf3d..3b81c426627d 100644
--- a/dev-python/hypothesis/hypothesis-6.124.3.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.124.3.ebuild
@@ -25,7 +25,7 @@ S="${WORKDIR}/${MY_P}/hypothesis-python"
LICENSE="MPL-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="cli"
RDEPEND="
diff --git a/dev-python/hypothesis/hypothesis-6.124.7.ebuild b/dev-python/hypothesis/hypothesis-6.125.2.ebuild
index 4486f30faf3d..4486f30faf3d 100644
--- a/dev-python/hypothesis/hypothesis-6.124.7.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.125.2.ebuild