summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/referencing')
-rw-r--r--dev-python/referencing/Manifest1
-rw-r--r--dev-python/referencing/referencing-0.36.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/referencing/Manifest b/dev-python/referencing/Manifest
index 0552de56138a..dac9b5104837 100644
--- a/dev-python/referencing/Manifest
+++ b/dev-python/referencing/Manifest
@@ -1 +1,2 @@
DIST referencing-0.35.1.tar.gz 62991 BLAKE2B b434d3b24bb01c7ea2b97300408571483ecfaa49b52867374a8734b4dafd06404c8b993757620329668fa01eb791c2a6f938aa4be20ff841fe691a4b47dcf6b3 SHA512 b737afb45bfb1adb91f457b78ab4a31a6f33839ef61095663fd66d91c09fc379d900f778bacaa36722770ce80eccd6a227a074cb44836e69205bed06165d033d
+DIST referencing-0.36.1.tar.gz 74661 BLAKE2B a5eb713a0f227f4e331169e7aed7691d12712279ce3851cc58da87e7ba41ba291a80066360f7d6fc6f5e170977ae1718717438c7383c9e33bfc0a14f30e4c805 SHA512 2e2cbe9614811a650cd1dd6a63dd42ddb152ed934e9f3cb93671965ae66b982d7fc5207412f3c3fc4216727cc54499c9a39102e20dfc6d6a668a5d5d4c3ec604
diff --git a/dev-python/referencing/referencing-0.36.1.ebuild b/dev-python/referencing/referencing-0.36.1.ebuild
new file mode 100644
index 000000000000..9f96720001ad
--- /dev/null
+++ b/dev-python/referencing/referencing-0.36.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest