summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/secretstorage/secretstorage-3.3.1.ebuild')
-rw-r--r--dev-python/secretstorage/secretstorage-3.3.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/secretstorage/secretstorage-3.3.1.ebuild b/dev-python/secretstorage/secretstorage-3.3.1.ebuild
deleted file mode 100644
index 783105f6acc2..000000000000
--- a/dev-python/secretstorage/secretstorage-3.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit distutils-r1
-
-MY_PN="SecretStorage"
-
-DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API"
-HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/jeepney-0.6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( !hppa? ( !sparc? ( !s390? (
- sys-apps/dbus
- virtual/secret-service
- ) ) ) )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-src_test() {
- case ${ARCH} in
- hppa|sparc)
- einfo "gnome-keyring is not supported on ${ARCH}, skipping tests"
- return
- ;;
- esac
-
- distutils-r1_src_test
-}
-
-python_test() {
- dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
- || die "tests failed with ${EPYTHON}"
-}