summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest4
-rw-r--r--dev-python/websockets/websockets-13.1.ebuild60
-rw-r--r--dev-python/websockets/websockets-14.0.ebuild60
-rw-r--r--dev-python/websockets/websockets-14.2.ebuild (renamed from dev-python/websockets/websockets-13.0.1.ebuild)4
4 files changed, 3 insertions, 125 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index d4e198b3256e..0de41c5c8345 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,6 +1,4 @@
DIST websockets-11.0.3-python3.12.patch.xz 4328 BLAKE2B 6ef94255ef5d95de8015eca14a5110373ab9ffadf4d1c86a892da1aac46caa2755cafeb643a222000a03262c1b1b1aea58132daff36981c00dbb68ce05484058 SHA512 421a6fb5a2a801850ea1fbaf890c11eac0f55ad288185f16f4244f316132591bc5a814636141ba3ada67aeff340f41de61d06c8db87010c858c1b0b02fd9b5ab
DIST websockets-12.0.gh.tar.gz 352120 BLAKE2B cab704e0ee44a7012ee58d515a5ea7380a97a3cbb8f55d105c00c8c2b9ed992b4c87435875474de32e5969fd92256bdec830db0571399a1d2e5fb719b23c2d83 SHA512 f17943d444ce275b709cf89453b2d2cce09f5af26f0460e226c2e24cfbb425c825963352e130dcd4201587606355375b525d8e5a02eccbffbb3985a108a3ed5e
-DIST websockets-13.0.1.gh.tar.gz 400436 BLAKE2B 3387cdc72117d2b1b0d1a5d3bc2444a243de2536b3937459221095b539172fab60972f4b1d0371c9c88222f8dcdf604a0371de1519728b40889a51ad6dd32029 SHA512 b187e7c443b9c6abbc7993f9c45dbd4fe83784d3ceb339b6e7d104cfa4da03450c25a8bf9dfa9c8626c3c91f2fe44c0dec6579ba830e0e20116a3e1e01be3bf1
-DIST websockets-13.1.gh.tar.gz 414934 BLAKE2B ac6ec67c360e88a7091c28e582b8a0e58fffb37b91f6cfe2b62fa91e1de10f94ba66b644e22f3ce34db698ec25c1685f682e3557058e30f162e1a6a39c19451e SHA512 f66c25c8c2a327840e424e1db3742f1e303df562fe59e91d44c15731d9e43d3d9b126253f2ffb2efeada63d3fd8b404480506554f263846d8d0d86da02f4d8aa
-DIST websockets-14.0.gh.tar.gz 424033 BLAKE2B c0181fee4dfc4c2b929d3b51edcdf1602e8c5e5c8595cd7b8df13b2f633434fd5a9ec3ac0a87e456eacd432fd1650ae4470ce5f5337b0391ccda57f38d5f58f4 SHA512 a32d6338ed70de0b99298e9b26c6a3f18a3b517633754c8b1fdbebfb407023f73d212e98db909a276c58aab6487db501540db0c8237280c1a311d8b0e7c1e4be
DIST websockets-14.1.gh.tar.gz 425408 BLAKE2B ebedf5bf27373cc05b6b82675bf7ff32b63f025e9bcee405a224c44d54e93b6a10d86a1deb1773e232fe1bb1680642e4553b9f5be999cb7523823b180a899840 SHA512 771c7d2e55f90de1307d8d662c2066397c0e2299f321dd3621df99cdf105f8d9d7583b70e7d1c51465174e9d35ba8db51eda559ca9bbd7ce74c90d1759df2e5d
+DIST websockets-14.2.gh.tar.gz 427526 BLAKE2B 2c6fca711b16e5c45d49320f86f7da2ef428573786dbecb57876978b8a2819d8074984d929a0ff16222a8131f175287ed66d5c19dd7ca12106fbe93449a3dda6 SHA512 b5b5ce455e5b68a14993ac1d02c6f417db6cc89cdb9b21e12ba1e1975050fdf7e1935e08a35d8fcb41f5e255385c72834627c989f0734d7015bc1817f6067fe9
diff --git a/dev-python/websockets/websockets-13.1.ebuild b/dev-python/websockets/websockets-13.1.ebuild
deleted file mode 100644
index 7e247066eed2..000000000000
--- a/dev-python/websockets/websockets-13.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/python-websockets/websockets/
- https://pypi.org/project/websockets/
-"
-# tests are missing pypi sdist, as of 11.0
-SRC_URI="
- https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-BDEPEND="
- test? (
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
- local -x BUILD_EXTENSION=yes
- else
- local -x BUILD_EXTENSION=no
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires DNS access
- # https://bugs.gentoo.org/909567
- tests/legacy/test_client_server.py::ClientServerTests::test_explicit_host_port
- tests/legacy/test_client_server.py::SecureClientServerTests::test_explicit_host_port
- # TODO
- tests/asyncio/test_server.py::ServerTests::test_close_server_keeps_handlers_running
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest tests -p rerunfailures --reruns=10 --reruns-delay=2
-}
diff --git a/dev-python/websockets/websockets-14.0.ebuild b/dev-python/websockets/websockets-14.0.ebuild
deleted file mode 100644
index 93fc44988e99..000000000000
--- a/dev-python/websockets/websockets-14.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/python-websockets/websockets/
- https://pypi.org/project/websockets/
-"
-# tests are missing pypi sdist, as of 11.0
-SRC_URI="
- https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="+native-extensions"
-
-BDEPEND="
- test? (
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
- local -x BUILD_EXTENSION=yes
- else
- local -x BUILD_EXTENSION=no
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires DNS access
- # https://bugs.gentoo.org/909567
- tests/legacy/test_client_server.py::ClientServerTests::test_explicit_host_port
- tests/legacy/test_client_server.py::SecureClientServerTests::test_explicit_host_port
- # TODO
- tests/asyncio/test_server.py::ServerTests::test_close_server_keeps_handlers_running
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest tests -p rerunfailures --reruns=10 --reruns-delay=2
-}
diff --git a/dev-python/websockets/websockets-13.0.1.ebuild b/dev-python/websockets/websockets-14.2.ebuild
index f009f4c556c4..3b6e296a0d67 100644
--- a/dev-python/websockets/websockets-13.0.1.ebuild
+++ b/dev-python/websockets/websockets-14.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE="+native-extensions"
BDEPEND="