summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astropy/Manifest1
-rw-r--r--dev-python/astropy/astropy-2.0.ebuild93
-rw-r--r--dev-python/astropy/files/astropy-2.0-external-python-pkgs.patch120
3 files changed, 214 insertions, 0 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 93eb031730c1..2cb34d56b18a 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1,2 +1,3 @@
DIST astropy-1.2.1.tar.gz 8179665 SHA256 0d7ef702166f26fed239b59fc12edcd5243ca5bf562a36202fd8c6b0270d6e48 SHA512 2ef37537a4c6b2ec50a1d898f600978475c9c5d2cb66ba19d06782656e9ddcb4aa6a8e53217e318448cedac45dac0dce0d8cc2fe94cddc15ebb306b3b0794595 WHIRLPOOL d37374f23a0121fdc92fa572facc248f0a571dacb8edcf1a9d0987d6a40287de199262ec01f654bd6ea5aece826e5588d2869558152adffe9ab490fa46f2e36d
DIST astropy-1.3.3.tar.gz 8427036 SHA256 ed093e033fcbee5a3ec122420c3376f8a80f74663214560727d3defe82170a99 SHA512 15956d488a390ab3b4091146bffe6f192f22e7598d00e302c2bcf0ec9728911f48bef3ee4c71d331f58e57aec86292421d27f915ea16027a7f62c5d43f6a12e5 WHIRLPOOL a9246b1ba56ecda5eec42e89998f18da4987f611d1154ba8ef5d3480d398fd77c0fdad6c15614885ae722454b9c284b9281ee926fed0f39c314864a015bf658f
+DIST astropy-2.0.tar.gz 8217371 SHA256 cdd60fce57c2be5d93fdc39a8ddf3621c4099026f50617294875273321cd8f99 SHA512 b49289da6564539dc9321cd1bf4c8295ce9c659f501f7cdab6ef97cf34fcd80cd68d734178b99b8aa2ffccd6529b6c03629d384c7155804d12f467973cda90cc WHIRLPOOL e90586613c4426f875bbdc9387048a32a5424a1b7d3d11ff1ac0d349de899b7f3f4a2863247cb7329b5261afbe6e648663123aaf33a98c2ba39dc2d556f0dbd0
diff --git a/dev-python/astropy/astropy-2.0.ebuild b/dev-python/astropy/astropy-2.0.ebuild
new file mode 100644
index 000000000000..539de59e144f
--- /dev/null
+++ b/dev-python/astropy/astropy-2.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 xdg-utils
+
+MYPV=${PV/_/}
+S=${WORKDIR}/${PN}-${MYPV}
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MYPV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/jplephem[${PYTHON_USEDEP}]
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.10[${PYTHON_USEDEP}]
+ dev-python/objgraph[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},jpeg]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-astronomy/erfa-1.3:0=
+ >=sci-astronomy/wcslib-5:0=
+ >=sci-libs/cfitsio-3.410:0=
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ sys-libs/zlib:0=
+"
+DEPEND="
+ >=dev-python/astropy-helpers-2[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.10[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ ${RDEPEND}
+ media-gfx/graphviz
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx-gallery[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ export mydistutilsargs="--offline"
+ export ASTROPY_USE_SYSTEM_PYTEST=True
+ rm -r ${PN}_helpers || die
+ rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ cat >> setup.cfg <<-EOF
+
+ [build]
+ use_system_libraries=1
+ EOF
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${T}" PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_docs --no-intersphinx
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/astropy/files/astropy-2.0-external-python-pkgs.patch b/dev-python/astropy/files/astropy-2.0-external-python-pkgs.patch
new file mode 100644
index 000000000000..117cb8563b77
--- /dev/null
+++ b/dev-python/astropy/files/astropy-2.0-external-python-pkgs.patch
@@ -0,0 +1,120 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Thu, 12 Jan 2017 11:37:47 +0100
+Subject: Use external python modules instead of convenience copies
+bicatali@gentoo.org: Edit to remove jsviewer debian internals
+
+---
+ astropy/coordinates/angle_utilities.py | 2 +-
+ astropy/extern/configobj.py | 5 ++++-
+ astropy/extern/six.py | 2 +-
+ astropy/units/format/cds.py | 4 ++--
+ astropy/units/format/generic.py | 4 ++--
+ astropy/units/format/ogip.py | 4 ++--
+ 8 files changed, 23 insertions(+), 18 deletions(-)
+
+diff --git a/astropy/coordinates/angle_utilities.py b/astropy/coordinates/angle_utilities.py
+index cfa894e..bb8fb7d 100644
+--- a/astropy/coordinates/angle_utilities.py
++++ b/astropy/coordinates/angle_utilities.py
+@@ -64,7 +64,7 @@ class _AngleParser(object):
+
+ @classmethod
+ def _make_parser(cls):
+- from ..extern.ply import lex, yacc
++ from ply import lex, yacc
+
+ # List of token names.
+ tokens = (
+diff --git a/astropy/extern/configobj.py b/astropy/extern/configobj.py
+index 8d1bd8c..e3bb0e0 100644
+--- a/astropy/extern/configobj.py
++++ b/astropy/extern/configobj.py
+@@ -7,5 +7,8 @@ currently installed version of python.
+ Also, this should actually never actually show up as a docstring, because
+ it should get overwritten by the appropriate configobj docstring.
+ """
++from __future__ import absolute_import
++import validate
++import configobj
++
+
+-from .configobj import configobj, validate, __doc__
+diff --git a/astropy/extern/six.py b/astropy/extern/six.py
+index 5398fc0..fb3a30c 100644
+--- a/astropy/extern/six.py
++++ b/astropy/extern/six.py
+@@ -13,7 +13,7 @@ _SIX_MIN_VERSION = StrictVersion('1.10.0')
+ # Update this to prevent Astropy from using its bundled copy of six
+ # (but only if some other version of at least _SIX_MIN_VERSION can
+ # be provided)
+-_SIX_SEARCH_PATH = ['astropy.extern.bundled.six', 'six']
++_SIX_SEARCH_PATH = ['six']
+
+
+ def _find_module(name, path=None):
+diff --git a/astropy/units/format/cds.py b/astropy/units/format/cds.py
+index e40c1cf..0d5e033 100644
+--- a/astropy/units/format/cds.py
++++ b/astropy/units/format/cds.py
+@@ -78,7 +78,7 @@ class CDS(Base):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -142,7 +142,7 @@ class CDS(Base):
+ <https://bitbucket.org/nxg/unity/>`_.
+ """
+
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+
+diff --git a/astropy/units/format/generic.py b/astropy/units/format/generic.py
+index 974ca25..7d40dfe 100644
+--- a/astropy/units/format/generic.py
++++ b/astropy/units/format/generic.py
+@@ -103,7 +103,7 @@ class Generic(Base):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -178,7 +178,7 @@ class Generic(Base):
+ formats, the only difference being the set of available unit
+ strings.
+ """
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+
+diff --git a/astropy/units/format/ogip.py b/astropy/units/format/ogip.py
+index e429407..e80e35a 100644
+--- a/astropy/units/format/ogip.py
++++ b/astropy/units/format/ogip.py
+@@ -110,7 +110,7 @@ class OGIP(generic.Generic):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -180,7 +180,7 @@ class OGIP(generic.Generic):
+ <https://bitbucket.org/nxg/unity/>`_.
+ """
+
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+